码迷,mamicode.com
首页 > 其他好文 > 详细

PAT-ADVANCED-1001-A+B Format

时间:2015-07-20 22:45:56      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

 

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

 将a+b的和从低到高,三位的隔开.

在这里我们直接使用stack来存储,需要注意res=0的情况;输出第一个和剩下来的补全问题

技术分享
#include <bits/stdc++.h>
#define LL long long
#define MAXN 100000+50
#define MOD 1000000007
using namespace std;


stack<int> s;
int  main(){
    int res, a, b;
    scanf("%d%d", &a, &b);
    res = a+b;
    if(!res){
        printf("0");
        return 0;
    }
    if(res < 0){
        printf("-");
        res = -res;
    }
    while(res){
        s.push(res%1000);
        res /= 1000;
    }
    bool flag = false;
    while(!s.empty()){
        if(!flag){
            printf("%d", s.top());
            s.pop();
            flag = true;
        }
        else{
            printf(",%03d", s.top());
            s.pop();
        }
    }
    return 0;
}
CAPOUIS‘CODE

 

PAT-ADVANCED-1001-A+B Format

标签:

原文地址:http://www.cnblogs.com/capouis/p/4662616.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!