码迷,mamicode.com
首页 > 其他好文 > 详细

杭电1003

时间:2015-07-20 23:38:24      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:

题目链接 点击打开链接

Problem DescriptionGiven a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5 
Sample OutputCase 1:
14 1 4

Case 2:
7 1 6

注意事项:
1:输入数据有可能为负数;
2:输出格式要注意。

#include <stdio.h> 
int a[100010]; 
int main(void)
{
<span style="white-space:pre">	</span>int n,m,k = 1,i,pos,start,end;
<span style="white-space:pre">	</span>scanf("%d",&n);
<span style="white-space:pre">	</span>while(n--)
<span style="white-space:pre">	</span>{
<span style="white-space:pre">		</span>scanf("%d",&m);
<span style="white-space:pre">	</span>for(i = 1; i <= m; i++)
<span style="white-space:pre">	</span>{
<span style="white-space:pre">		</span>scanf("%d",&a[i]);
<span style="white-space:pre">	</span>}
<span style="white-space:pre">	</span>int s = 0,max = a[1];
<span style="white-space:pre">	</span>pos = start = end = 1;
<span style="white-space:pre">	</span>for(i = 1; i <= m; i++)
<span style="white-space:pre">	</span>{
<span style="white-space:pre">		</span>if(s < 0)
<span style="white-space:pre">		</span>{
<span style="white-space:pre">			</span>s = a[i];
<span style="white-space:pre">			</span>pos = i;
<span style="white-space:pre">		</span>}
<span style="white-space:pre">		</span>else
<span style="white-space:pre">			</span>s += a[i];
<span style="white-space:pre">		</span>if(max < s)
<span style="white-space:pre">		</span>{
<span style="white-space:pre">			</span>max = s;
<span style="white-space:pre">			</span>start = pos;
<span style="white-space:pre">			</span>end = i;
<span style="white-space:pre">		</span>}
<span style="white-space:pre">	</span>}
<span style="white-space:pre">	</span>printf("Case %d:\n%d %d %d\n",k++,max,start,end);
<span style="white-space:pre">	</span>if(n > 0)
<span style="white-space:pre">		</span>printf("\n");
<span style="white-space:pre">	</span>}
<span style="white-space:pre">	</span>return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

杭电1003

标签:

原文地址:http://blog.csdn.net/u013224148/article/details/46973767

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!