码迷,mamicode.com
首页 > 其他好文 > 详细

Test for Job (poj 3249 记忆化搜索)

时间:2015-07-20 23:39:31      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:test for job   poj 3249   记忆化搜索   

Language:
Test for Job
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 9733   Accepted: 2245

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It‘s hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases. 
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads. 
The next n lines each contain a single integer. The ith line describes the net profit of the city iVi (0 ≤ |Vi| ≤ 20000) 
The next m lines each contain two integers xy indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city. 

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint

技术分享

Source



题意:n个点m条边的有向图,每个点有权值,现在从入度为零的点出发到出度为零的点,求路径上的权值之和最大为多少。

思路:点比较多,肯定不能用矩阵存图,要用到邻接表,建图时统计入度为零的点,从该点出发dfs,找出从这一点出发能得到的最大值。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

#define INF 0x3f3f3f3f
#define mod 1000000009
const int maxn = 100000+10;
const int MAXN = 1000000+10;
const int N = 1005;

struct Edge
{
    int u,v,next;
}edge[MAXN];

int num,head[maxn];
int weight[maxn],in[maxn];
int n,m;
int vis[maxn];

void init()
{
    num=0;
    mem(head,-1);
    mem(vis,0);
    mem(in,0);
}

void addedge(int u,int v)
{
    edge[num].u=u;
    edge[num].v=v;
    edge[num].next=head[u];
    head[u]=num++;
}

int dfs(int u)
{
    if (vis[u]) return vis[u];
    int Max=-INF;
    for (int i=head[u];~i;i=edge[i].next)
    {
        int v=edge[i].v;
        Max=max(Max,dfs(v));
    }
    if (Max==-INF) Max=0;
    vis[u]=Max+weight[u];
    return vis[u];
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("C:/Users/lyf/Desktop/IN.txt","r",stdin);
#endif
    int i,j,u,v;
    while (~sff(n,m))
    {
        init();
        for (i=1;i<=n;i++)
            sf(weight[i]);
        for (i=0;i<m;i++)
        {
            sff(u,v);
            in[v]++;
            addedge(u,v);
        }
        int ans=-INF;
        for (i=1;i<=n;i++)
            if (in[i]==0)
                ans=max(ans,dfs(i));
        pf("%d\n",ans);
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

Test for Job (poj 3249 记忆化搜索)

标签:test for job   poj 3249   记忆化搜索   

原文地址:http://blog.csdn.net/u014422052/article/details/46973379

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!