码迷,mamicode.com
首页 > 其他好文 > 详细

uva 673 Parentheses Balance

时间:2015-07-20 23:45:00      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:

 

Parentheses Balance

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)if it is the empty string
(b)if A and B are correct, AB is correct,
(c)if A is correct, (A) and [A] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input

The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.

Output

A sequence of Yes or No on the output file.

Sample Input

3
([])
(([()])))
([()[]()])()

 Sample Output

Yes
No
Yes


Miguel Revilla
2000-08-14
题意:
如果有一个‘(‘那么就要有一个)与它匹配,如果有一个‘[‘那么就要有一个‘]‘与它匹配.。如果都满足,输出”YES“,else 输出”NO“.
思路;
建立一个栈,左括号’[‘,‘(‘都入栈,右括号‘)‘,‘]‘都出栈依次进行下去,如果栈为空,则满足条件,输出“YES”,如果不满足条件,则输出”NO“。
代码:
#include<cstdio>
#include<stack>
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
        getchar();
        while(n--)
        {
            char a[130];
            stack<char> s;
            gets(a);
            int flag=0;
    for(int i=0;a[i]!='\0';i++)
        {
            if(a[i]=='('||a[i]=='[')
                 s.push(a[i]);
            else if(a[i]==')')
            {
                if(!s.empty()&&s.top()=='(')   s.pop();
                else
                    {flag=1;break;}
            }
            else if(a[i]==']')
            {
                if(!s.empty()&&s.top()=='[')
                    s.pop();
                else {flag=1;break;}
            }

        }
        if(flag||!s.empty())   printf("No\n");
        else printf("Yes\n");
        }
    return 0;
}

 

 

版权声明:本文为博主原创文章,未经博主允许不得转载。

uva 673 Parentheses Balance

标签:

原文地址:http://blog.csdn.net/a1967919189/article/details/46972397

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!