码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-1086-You can Solve a Geometry Problem too 判断线段是否相交

时间:2015-07-20 23:47:50      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:

You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8683 Accepted Submission(s): 4227


Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point.

Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the number of intersections, and one line one case.

Sample Input
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0

Sample Output
1 3

Author
lcy

Recommend
We have carefully selected several similar problems for you: 1392 2108 2150 1348 1147

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
const double esp=1e-7;
struct point{
	double x,y;
}p[110],q[110];
double cross(point a,point b,point c){
	return (c.x-a.x)*(c.y-b.y)-(c.x-b.x)*(c.y-a.y);
}
bool insert(point aa,point bb,point cc,point dd){
	if(max(aa.x,bb.x)<min(cc.x,dd.x))  return false;
	if(max(aa.y,bb.y)<min(cc.y,dd.y))  return false;
	if(max(cc.x,dd.x)<min(aa.x,bb.x))  return false;
	if(max(cc.y,dd.y)<min(aa.y,bb.y))  return false;
	if(cross(aa,bb,cc)*cross(aa,bb,dd)>0) return false;
	if(cross(cc,dd,aa)*cross(cc,dd,bb)>0) return false;
	return true;
}
int main(){
	int n;
	while(~scanf("%d",&n),n){
		int i,j;
		double s1,s2;
		for(i=1;i<=n;++i){
			scanf("%lf%lf%lf%lf",&p[i].x,&p[i].y,&q[i].x,&q[i].y);
		}
		int ncase=0;
		for(i=1;i<=n;++i){
			for(j=i+1;j<=n;++j){
			    if(insert(p[i],q[i],p[j],q[j])) ncase++;
			}
		}
		printf("%d\n",ncase);
     
	}
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-1086-You can Solve a Geometry Problem too 判断线段是否相交

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/46972393

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!