码迷,mamicode.com
首页 > 其他好文 > 详细

KMP(1-模板题)

时间:2015-07-21 12:43:02      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:

Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input

2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output

6 -1
助于理解KMP的链接:http://m.blog.csdn.net/blog/MAOTIANWANG/34466483
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn=1000008;
int t[maxn];
int s[maxn];
int n[maxn];
int len,len1;
void get_next()
{
    int i=0;
    int j=-1;
    n[0]=-1;
    while(i<len)
    {
        if(j==-1||t[i]==t[j])
        {
            i++;
            j++;
            n[i]=j;
        }
        else
            j=n[j];
    }
}
void kmp()
{
   int i=0;
   int j=0;
   while(i<len1)
   {
       if(s[i]==t[j]||j==-1)
       {
           i++;
           j++;
       }
       else
        j=n[j];
       if(j==len)
       {
           printf("%d\n",i-len+1);
           return ;
       }
   }
   printf("-1\n");
}
int main()
{
    int m;
    scanf("%d",&m);
    while(m--)
    {
        memset(n,0,sizeof(n));
        scanf("%d%d",&len1,&len);
        for(int i=0; i<len1; i++)
        {
            scanf("%d",&s[i]);
        }
        for(int j=0; j<len; j++)
        {
            scanf("%d",&t[j]);
        }
        get_next();
        kmp();
    }
    return 0;
}

 

KMP(1-模板题)

标签:

原文地址:http://www.cnblogs.com/tianmin123/p/4663854.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!