码迷,mamicode.com
首页 > 其他好文 > 详细

LA 3026 Period (strings)

时间:2015-07-21 12:46:50      阅读:86      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 ≤ N ≤ 1 000 000) ? the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output ?Test case #? and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4


解析:根据后缀函数的定义,“错位部分”长度为i - f[i]。如果这i个字符组成一个周期串,那么“错位”部分恰好是一个循环节,因此k * (i - f[i]) = i(注意k > 1,因此i - f[i]不能等于i,即必须有f[i] > 0)。不难证明反过来也成立。




AC代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1000000 + 10;
char p[maxn];
int f[maxn];

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk

    int n, kase = 0;
    while(scanf("%d", &n) == 1 && n){
        scanf("%s", p);
        f[0] = f[1] = 0;     //递推边界初值
        for(int i = 1; i < n; i++){
            int j = f[i];
            while(j && p[i] != p[j]) j = f[j];
            f[i+1] = (p[i] == p[j] ? j+1 : 0);
        }

        printf("Test case #%d\n", ++kase);
        for(int i = 2; i <= n; i++)
            if(f[i] > 0 && i % (i - f[i]) == 0) printf("%d %d\n", i, i / (i - f[i]));
        puts("");
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

LA 3026 Period (strings)

标签:

原文地址:http://blog.csdn.net/u013446688/article/details/46984043

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!