码迷,mamicode.com
首页 > 其他好文 > 详细

Geometry Made Simple

时间:2015-07-21 12:50:20      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Mathematics can be so easy when you have a computer. Consider the following example. You probably know that in a right-angled triangle, the length of the three sides a, b, c (where c is the longest side, called the hypotenuse) satisfy the relation a*a+b*b=c*c. This is called Pythagora‘s Law.

Here we consider the problem of computing the length of the third side, if two are given.

技术分享

Input

The input contains the descriptions of several triangles. Each description consists of a line containing three integers a, b and c, giving the lengths of the respective sides of a right-angled triangle. Exactly one of the three numbers is equal to -1 (the ‘unknown‘ side), the others are positive (the ‘given‘ sides).

A description having a=b=c=0 terminates the input.


Output

For each triangle description in the input, first output the number of the triangle, as shown in the sample output. Then print "Impossible." if there is no right-angled triangle, that has the ‘given‘ side lengths. Otherwise output the length of the ‘unknown‘ side in the format "s = l", where s is the name of the unknown side (a, b or c), and l is its length. l must be printed exact to three digits to the right of the decimal point.

Print a blank line after each test case.


Sample Input

3 4 -1
-1 2 7
5 -1 3
0 0 0


Sample Output

Triangle #1
c = 5.000

Triangle #2
a = 6.708

Triangle #3
Impossible.


刚开始运行时由于考虑不周到少考虑了一些情况二导致出错,如a,c,b中其中一个为0的情况,还有求边长时还要考虑c小于a或b的情况,还要考虑个边长小于一的情况;

输出时Impossible后面有一个‘.’要记住,Triangle #1后面的一需要变化,c = 5.000中c与等号之间有空格,要注意



#include<stdio.h>

#include<math.h>
int main()
{
float a,b,c;
int i=1;
while(scanf("%f%f%f",&a,&b,&c)&&(a!=0||b!=0||c!=0))
{
printf("Triangle #%d\n",i);
if(a==0||b==0||c==0)
{
i++;
printf("Impossible.\n\n");
continue;
}
if(a==-1)
{
i++;
if(c<=b||c<0||b<0)
printf("Impossible.\n\n");
else
printf("a = %.3f\n\n",sqrt(c*c-b*b));
}


if(b==-1)
{
i++;
if(c<=a||c<0||a<0)
printf("Impossible.\n\n");
else
printf("b = %.3f\n\n",sqrt(c*c-a*a));
}


if(c==-1)
{
i++;
if(a<0||b<0)
printf(".\n\n");
else
printf("c = %.3f\n\n",sqrt(a*a+b*b));
    }


}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Geometry Made Simple

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/46983309

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!