标签:des style blog http java color
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42155 Accepted Submission(s): 23093
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to
move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
Sample Output
#include<stdio.h>
int main()
{
int n,i,t,a,b;
while(scanf("%d",&n)&&n!=0)
{
t=0,a=0;
for(i=0;i<n;i++)
{
scanf("%d",&b);
if(a<=b)
t+=5+6*(b-a);
else
t+=5+4*(a-b);
a=b;
}
printf("%d\n",t);
}
return 0;
}
HDU1008:Elevator,布布扣,bubuko.com
HDU1008:Elevator
标签:des style blog http java color
原文地址:http://blog.csdn.net/u013487051/article/details/37311779