码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2255

时间:2015-07-21 17:09:30      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

Description

技术分享Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

                                    D
                                   /                                   /                                    B     E
                                / \                                    /   \     \ 
                              A     C     G
                                         /
                                        /
                                       F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)  

Input is terminated by end of file.

Output Specification

For each test case, recover Valentine‘s binary tree and print one line containing the tree‘s postorder traversal (left subtree, right subtree, root).  

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB
题意:分别给出一棵树的先序遍历和中序遍历,要你求出这棵树的后序遍历。
前序遍历:根-->左子树-->右子树
中序遍历:左子树-->根-->右子树
后序遍历:左子树-->右子树-->根
思路:利用先序遍历和中序遍历找到树根,再找出左子树和右子树的树根,然后一直递归下去,就能求出后序遍历。
代码:
#include<cstdio>
#include<cstring>
#include<cstdlib>
struct tree//定义树
{
    char data;
    struct tree * left,*right;
};
struct tree *build(int n,char *s1,char *s2)//重建一个含n个节点的树。并返回根节点的树根
{
    if(n<=0)
        return NULL;
    int p=strchr(s2,s1[0])-s2;//后序遍历找到根的位置
    struct tree*root=(struct tree*)malloc(sizeof(struct tree));
    root->left=build(p,s1+1,s2);//建左树
    root->right=build(n-p-1,s1+p+1,s2+p+1);//建立右树
    root->data=s1[0];
    return root;
};
void out(struct tree*root)//后序遍历
{
    if(root==NULL)
        return ;
    out(root->left);
    out(root->right);
    printf("%c",root->data);
}
int main()
{
    char s1[80],s2[80];
    struct tree*root;
    int len;
    while(scanf("%s%s",s1,s2)!=EOF)
    {
        len=strlen(s1);
        root=build(len,s1,s2);
        out(root);
        printf("\n");
    }
    return 0;
}

 

版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 2255

标签:

原文地址:http://blog.csdn.net/a1967919189/article/details/46987183

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!