码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5294 Tricks Device 最短路建图+最小割

时间:2015-07-22 00:06:29      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:最短路   最小割   

链接:http://acm.hdu.edu.cn/showproblem.php?pid=5294

Tricks Device

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 375    Accepted Submission(s): 98


Problem Description
Innocent Wu follows Dumb Zhang into a ancient tomb. Innocent Wu’s at the entrance of the tomb while Dumb Zhang’s at the end of it. The tomb is made up of many chambers, the total number is N. And there are M channels connecting the chambers. Innocent Wu wants to catch up Dumb Zhang to find out the answers of some questions, however, it’s Dumb Zhang’s intention to keep Innocent Wu in the dark, to do which he has to stop Innocent Wu from getting him. Only via the original shortest ways from the entrance to the end of the tomb costs the minimum time, and that’s the only chance Innocent Wu can catch Dumb Zhang.
Unfortunately, Dumb Zhang masters the art of becoming invisible(奇门遁甲) and tricks devices of this tomb, he can cut off the connections between chambers by using them. Dumb Zhang wanders how many channels at least he has to cut to stop Innocent Wu. And Innocent Wu wants to know after how many channels at most Dumb Zhang cut off Innocent Wu still has the chance to catch Dumb Zhang.
 

Input
There are multiple test cases. Please process till EOF.
For each case,the first line must includes two integers, N(<=2000), M(<=60000). N is the total number of the chambers, M is the total number of the channels.
In the following M lines, every line must includes three numbers, and use ai、bi、li as channel i connecting chamber ai and bi(1<=ai,bi<=n), it costs li(0<li<=100) minute to pass channel i.
The entrance of the tomb is at the chamber one, the end of tomb is at the chamber N.
 

Output
Output two numbers to stand for the answers of Dumb Zhang and Innocent Wu’s questions.
 

Sample Input
8 9 1 2 2 2 3 2 2 4 1 3 5 3 4 5 4 5 8 1 1 6 2 6 7 5 7 8 1
 

Sample Output
2 6
 



题意:

1到n点有最短路。

问你 最少破坏多少条路会阻断所有最短路。

再问你 最多破坏多少边,仍有和原始图的最短路一样长度的最短路存在。


做法:

先跑最短路。

然后通过  dist[i]-dist[j] == map[j][i]

如果符合的话  map[j][i]就是 最短路中的一条边。

然后把这些最短路的边 建图,跑最大流,流量是有多少边权相同的重边,跑出来就是最小割,也就是阻断所有最短路的最小花费。花费是每破坏一条路为1。所以出来的值,就是破坏了多少的边。


然后如最大流同样的建边,跑最短路,边权为1,跑出来的最短路dist[n],就是  跨越边数最少的 最短路的边数了。 


#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#include <string.h>
using namespace std;

const int MAXN = 2200;//点数的最大值
const int MAXM = 800000;//边数的最大值
const int INF2 = 2000000000;
struct Edge1
{
    int to,next,cap,flow;
}edge[MAXM];//注意是MAXM
int tol;
int head[MAXN];
int gap[MAXN],dep[MAXN],cur[MAXN];
void init()
{
    tol = 0;
    memset(head,-1,sizeof (head));
}
void add (int u,int v,int w,int rw = 0)//网络流要有反向弧
{
    edge[tol].to = v; edge[tol].cap = w; edge[tol].flow = 0;
    edge[tol].next = head[u]; head[u] = tol++;
    edge[tol].to = u; edge[tol].cap = rw; edge[tol].flow = 0;
    edge[tol].next = head[v]; head[v] = tol++;
}
int Q[MAXN];
void BFS(int start,int end)
{
    memset(dep,-1,sizeof(dep));
    memset(gap,0,sizeof(gap));
    gap[0] = 1;
    int front = 0, rear = 0;
    dep[end] = 0;
    Q[rear++] = end;
    while(front != rear)
    {
        int u = Q[front++];
        for(int i = head[u]; i !=  -1; i = edge[i].next)
        {
            int v = edge[i]. to;
            if(dep[v] != -1)continue;
            Q[rear++] = v;
            dep[v] = dep[u] + 1;
            gap[dep[v]]++;
        }
    }
}
int S[MAXN];
int sap(int start,int end, int N)//有几个点
{
    BFS(start,end);
    memcpy(cur,head,sizeof(head));  
    int top = 0;
    int u = start;
    int ans = 0;
    int i;
    while(dep[start] < N)
    {
        if(u == end)
        {
            int Min = INF2;
            int inser;
            for( i = 0;i < top;i++)
            {
                if(Min > edge[S[i]].cap - edge[S[i]].flow)
                {
                    Min = edge[S[i]].cap - edge[S[i]].flow;
                    inser = i;
                }
            }
            for( i = 0;i < top;i++)
            {
                edge[S[i]]. flow += Min;
                edge[S[i]^1].flow -= Min;
            }
            ans += Min;
            top = inser;
            u = edge[S[top]^1].to;
            continue;
        }
        bool flag =  false;
        int v;
        for( i = cur[u]; i != -1; i = edge[i]. next)
        {
            v = edge[i]. to;
            if(edge[i].cap - edge[i].flow && dep[v]+1 == dep[u])
            {
                flag =  true;
                cur[u] = i;
                break;
            }
        }
        if(flag)
        {
            S[top++] = cur[u];
            u = v;
            continue;
        }
        int Min = N;
        for( i = head[u]; i !=  -1; i = edge[i].next)
        {
            if(edge[i].cap - edge[i].flow && dep[edge[i].to] < Min)
            {
                Min = dep[edge[i].to];
                cur[u] = i;
            }
        }
        gap[dep[u]]--;
        if(!gap[dep[u]]) return ans;
        dep[u] = Min + 1;
        gap[dep[u]]++;
        if(u != start)u = edge[S[--top]^1].to;
    }
    return ans;
} 



#define typec int
typec INF=0x3f3f3f3f;//防止后面溢出,这个不能太大
bool vis[MAXN];
int pre[MAXN];
void Dijkstra(typec cost[][MAXN],typec lowcost[],int n,int beg)
{
    for(int i=0;i<n;i++)
    {
        lowcost[i]=INF;
        vis[i]=false;
        pre[i]=-1;
    }
    lowcost[beg]=0;
    for(int j=0;j<n;j++)
    {
        int k=-1;
        int Min=INF;
        for(int i=0;i<n;i++)
            if(!vis[i]&&lowcost[i]<Min)
            {
                Min=lowcost[i];
                k=i;
            }
            if(k==-1)break;
            vis[k]=true;
            for(int i=0;i<n;i++)
                if(!vis[i]&&lowcost[k]+cost[k][i]<lowcost[i])
                { 
                    lowcost[i]=lowcost[k]+cost[k][i];
                    pre[i]=k;
                }
    }
}
int cost2[MAXN][MAXN];
int dist2[MAXN];


int cost[MAXN][MAXN];
int num[MAXN][MAXN];
int has[MAXN];
int dist[MAXN];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        memset(cost,INF,sizeof cost);
        memset(num,0,sizeof num);
        for(int i=0;i<n;i++) 
            cost[i][i]=0;

        for(int i=1;i<=m;i++)//双向  有重边
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w); 
            u--;
            v--;
            if(cost[u][v]>w)
            {
                cost[u][v]=w;
                cost[v][u]=w;
                num[u][v]=1;
                num[v][u]=1;
            }
            else if(cost[u][v]==w)
            {
                num[u][v]++;
                num[v][u]++;
            }

        }
        Dijkstra(cost,dist,n,0);// wuxiangda  bulian  
         
     

        memset(cost2,INF,sizeof cost2); 
        for(int i=0;i<n;i++) 
            cost2[i][i]=0;

        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(i!=j)
                if(dist[i]-dist[j]==cost[i][j])
                {
                    cost2[j][i]=1;
                    add(j,i,num[i][j]); 
                }
            }
        } 
        Dijkstra(cost2,dist2,n,0);
        printf("%d %d\n",sap(0,n-1,n),m-dist2[n-1]); 
    } 
    return 0; 
}





版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 5294 Tricks Device 最短路建图+最小割

标签:最短路   最小割   

原文地址:http://blog.csdn.net/u013532224/article/details/46992973

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!