码迷,mamicode.com
首页 > 其他好文 > 详细

POJ-1961-Period

时间:2015-07-22 09:21:28      阅读:102      评论:0      收藏:0      [点我收藏+]

标签:

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) ? the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input

3
aaa
12
aabaabaabaab
0
 

Sample Output

Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
也是KMP中循环节的模板题,注意的是输出的时候要从头开始遍历
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=1000001;
char a[maxn];
char b[maxn];
int  n[maxn];
int len,len1;
void get_next()
{
    int i=0;
    int j=-1;
    n[0]=-1;
    while(i<len)
    {
        if(j==-1||a[i]==a[j])
        {
            i++;
            j++;
            n[i]=j;
        }
        else
            j=n[j];
    }
}
int main()
{
    int q=1;
    while(scanf("%d",&len)!=EOF&&len)
    {
        memset(n,0,sizeof(n));
            scanf("%s",a);
        get_next();
        printf("Test case #%d\n",q++);
        for(int i=2;i<=len;i++)
        {
            if(i%(i-n[i])==0&&n[i])
            {
                printf("%d %d\n",i,i/(i-n[i]));
            }
        }
        printf("\n");
    }
    return 0;
}

 

POJ-1961-Period

标签:

原文地址:http://www.cnblogs.com/tianmin123/p/4666317.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!