码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2421 Constructing Roads(kruskal)(基础)

时间:2015-07-22 10:43:38      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:poj   kruskal   

Constructing Roads
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 20643   Accepted: 8697

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题意:
首先给一个数字N,代表多少个村庄,然后就是N*N的矩阵,代表两两村庄的距离。再给一个数Q,接下来Q行:a,b表示第a个与第b个村庄已经相连。求全部村庄联通情况下还需要连接的最短路长。

思路:
很明显的kruskal算法的应用。不过让我想郁闷的是因为我从早上写到晚上,到了晚上十点多有点累就不愿看英文题,直接找题解了解题意,结果别人题意解释的好复杂,我看完好像抽人。。。

代码:
//252K	63MS
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
#define inf 0xfffffff
typedef struct node
{
    int l,r;
    int w;
    bool operator < (const node &a) const
    {
        return w < a.w;
    }
}node;
node p[10010];
int pre[110];
int n,m;
int num;//边的个数

int Find(int x)
{
    return pre[x]==x?pre[x]:Find(pre[x]);
}

int Union(int a,int b)
{
    int f1=Find(a),f2=Find(b);
    if(f1!=f2)
    {
        pre[f1]=f2;
        return 1;
    }
    return 0;
}

void kruskal()
{
    int sum=0;
    for(int i=0;i<num;i++)
    {
        if(!Union(p[i].l,p[i].r))
            continue;
        sum+=p[i].w;
    }
    printf("%d\n",sum);
}

int main()
{
    scanf("%d",&n);
    num=0;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            p[num].l=i;
            p[num].r=j;
            scanf("%d",&p[num++].w);
        }
    }
    for(int i=0;i<=n;i++)
        pre[i]=i;
    scanf("%d",&m);
    int a,b;int f1,f2;
    while(m--)
    {
        scanf("%d%d",&a,&b);
        Union(a,b);
    }
    sort(p,p+num);
    kruskal();
    return 0;
}






版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 2421 Constructing Roads(kruskal)(基础)

标签:poj   kruskal   

原文地址:http://blog.csdn.net/kaisa158/article/details/46998251

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!