码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2752 Seek the Name, Seek the Fame (KMP纯模版)

时间:2015-07-22 10:53:48      阅读:115      评论:0      收藏:0      [点我收藏+]

标签:poj   编程   算法   acm   kmp   

Seek the Name, Seek the Fame
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 13840   Accepted: 6887

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father‘s name and the mother‘s name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father=‘ala‘, Mother=‘la‘, we have S = ‘ala‘+‘la‘ = ‘alala‘. Potential prefix-suffix strings of S are {‘a‘, ‘ala‘, ‘alala‘}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby‘s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18

1 2 3 4 5

#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
char cnt[400004];
int next[400004];

void get_next(char *s,int len)
{
    next [0]=-1;
    int j=-1,i=0;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int main()
{
    while(scanf("%s",cnt)!=EOF)
    {
        stack<int>sk;
        int k=strlen(cnt);
        memset(next,0,sizeof(next));
        get_next(cnt,strlen(cnt));

        int t;
        while(k>0)
        {
            sk.push(k);
            t=next[k];
            k=t;
        }
        while(!sk.empty())
        {
            cout<<sk.top()<<" ";
            sk.pop();
        }
        cout<<endl;
    }
    return 0;
}




版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 2752 Seek the Name, Seek the Fame (KMP纯模版)

标签:poj   编程   算法   acm   kmp   

原文地址:http://blog.csdn.net/lsgqjh/article/details/46997495

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!