码迷,mamicode.com
首页 > 其他好文 > 详细

TOYS (poj 2381 叉积+二分)

时间:2015-07-22 18:53:30      阅读:102      评论:0      收藏:0      [点我收藏+]

标签:toys   poj 2381   叉积+二分   

Language:
TOYS
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 11718   Accepted: 5653

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John‘s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
技术分享 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

Source



题意:给m个点的坐标,落在n+1个区域中,问各个区域有多少个点。

思路:利用叉积去判断点在线段的哪一侧,二分解决。今天开始慢慢接触计算几何了,然而网络流还没玩顺溜=-=

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

#define INF 0x3f3f3f3f
#define mod 1000000009
const int maxn = 5500;
const int MAXN = 2005;
const int N = 1005;

int n,m;
int x1,Y1,x2,y2;

struct Point
{
    int x,y;
    Point(){}
    Point(int _x,int _y)
    {
        x=_x; y=_y;
    }
    Point operator-(const Point &b)const
    {
        return Point(x-b.x,y-b.y);
    }
    int operator*(const Point &b)const
    {
        return x*b.x+y*b.y;
    }
    int operator^(const Point &b)const
    {
        return x*b.y-y*b.x;
    }
};

struct Line
{
    Point s,e;
    Line(){}
    Line(Point _s,Point _e)
    {
        s=_s;e=_e;
    }
};

int xmulti(Point p0,Point p1,Point p2)  //叉积
{
    return (p2-p0)^(p1-p0);
}

Line line[maxn];
int ans[maxn];

void solve()
{
    int x,y;
    Point p;
    mem(ans,0);
    while (m--)
    {
        sff(x,y);
        p=Point(x,y);
        int l=0,r=n,temp;
        while (l<=r)
        {
            int mid=(l+r)>>1;
            if (xmulti(p,line[mid].s,line[mid].e)<0)
                l=mid+1;
            else
            {
                temp=mid;
                r=mid-1;
            }
        }
        ans[temp]++;
    }
    for (int i=0;i<=n;i++)
        pf("%d: %d\n",i,ans[i]);
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("C:/Users/lyf/Desktop/IN.txt","r",stdin);
#endif
    int i,j;
    int flag=0;
    while (sf(n),n)
    {
        sf(m);
        sff(x1,Y1);
        sff(x2,y2);
        if (flag)
            pf("\n");
        flag=1;
        int a,b;
        for (i=0;i<n;i++)
        {
            sff(a,b);
            line[i]=Line(Point(a,Y1),Point(b,y2));
        }
        line[n]=Line(Point(x2,Y1),Point(x2,y2));
        solve();
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

TOYS (poj 2381 叉积+二分)

标签:toys   poj 2381   叉积+二分   

原文地址:http://blog.csdn.net/u014422052/article/details/47005943

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!