码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5288 OO’s Sequence(数学啊 多校2015)

时间:2015-07-22 20:56:40      阅读:363      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5288


Problem Description
OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there‘s no j(l<=j<=r,j<>i) satisfy ai mod aj=0,now OO want to know
i=1nj=inf(i,j) mod 109+7.

 

Input
There are multiple test cases. Please process till EOF.
In each test case: 
First line: an integer n(n<=10^5) indicating the size of array
Second line:contain n numbers ai(0<ai<=10000)
 

Output
For each tests: ouput a line contain a number ans.
 

Sample Input
5 1 2 3 4 5
 

Sample Output
23
 

Author
FZUACM
 

Source

题意:

给出n个数,让找到所有的区间内不能整除其它数的数的个数之和 !

PS:

技术分享

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define maxn 100017
#define LL __int64
const int mod = 1e9+7;
LL l[maxn], r[maxn];//存储左边因子,右边因子的位置
LL a[maxn];
int main()
{
    int n;
    LL pre[maxn], last[maxn];
    while(~scanf("%d",&n))
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%I64d",&a[i]);
            l[i] = 1;
            r[i] = n;//初始化最左边的因子和最右边的因子都是本身
        }
        memset(pre,0,sizeof(pre));
        memset(last,0,sizeof(last));
        for(int i = 1; i <= n; i++)
        {
            for(int j = a[i]; j <= 10000; j+=a[i])//枚举a[i]的倍数
            {
                if(pre[j]!=0 && r[pre[j]] == n)//如果j已经出现并且在右边最近的因子还没有找到
                {
                    r[pre[j]] = i-1;
                }
            }
            pre[a[i]] = i;
        }
        for(int i = n; i >= 1; i--)
        {
            for(int j = a[i]; j <= 10000; j+=a[i])//枚举a[i]的倍数
            {
                if(last[j]!=0 && l[last[j]] == 1)//如果j已经出现并且在左边最近的因子还没有找到
                {
                    l[last[j]] = i+1;
                }
            }
            last[a[i]] = i;
        }
//        for(int i=1;i<=n;i++){
//            printf("%d %I64d %I64d  %I64d\n",i,l[i],r[i],(i-l[i]+1)*(r[i]-i+1));
//        }
        LL ans = 0;
        for(int i = 1; i <= n; i++)
        {
            ans+=((LL)(i-l[i]+1)*(r[i]-i+1))%mod;
            ans%=mod;
        }

        printf("%I64d\n",ans);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5288 OO’s Sequence(数学啊 多校2015)

标签:

原文地址:http://blog.csdn.net/u012860063/article/details/47008889

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!