码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-1178-Heritage from father【科学计数法表示】

时间:2015-07-22 20:56:35      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:

Heritage from father

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 6076 Accepted Submission(s): 2214


Problem Description
Famous Harry Potter,who seemd to be a normal and poor boy,is actually a wizard.Everything changed when he had his birthday of ten years old.A huge man called ‘Hagrid‘ found Harry and lead him to a new world full of magic power.
If you‘ve read this story,you probably know that Harry‘s parents had left him a lot of gold coins.Hagrid lead Harry to Gringotts(the bank hold up by Goblins). And they stepped into the room which stored the fortune from his father.Harry was astonishing ,coz there were piles of gold coins.
The way of packing these coins by Goblins was really special.Only one coin was on the top,and three coins consisted an triangle were on the next lower layer.The third layer has six coins which were also consisted an triangle,and so on.On the ith layer there was an triangle have i coins each edge(totally i*(i+1)/2).The whole heap seemed just like a pyramid.Goblin still knew the total num of the layers,so it‘s up you to help Harry to figure out the sum of all the coins.

Input
The input will consist of some cases,each case takes a line with only one integer N(0<N<2^31).It ends with a single 0.

Output
对于每个输入的N,输出一行,采用科学记数法来计算金币的总数(保留三位有效数字)

Sample Input
1 3 0

Sample Output
1.00E0 1.00E1
Hint
Hint
when N=1 ,There is 1 gold coins. when N=3 ,There is 1+3+6=10 gold coins.

Source

Recommend
JGShining | We have carefully selected several similar problems for you: 1205 1030 1143 1181 1014

#include<stdio.h>
#include<math.h>
int main(){
	int n;
	while(scanf("%d",&n),n){
		double t=1.0*n*(n+1)*(n+2)/6;  // 此处要用double型,double的指数范围远比  __int64 大,所以之前用的__int64,结果一直WA!!
		int  k=(int)log10(t);
		double a=pow(10,log10(t)-k);
		printf("%.2lfE%d\n",a,k);
	}
}

  float:
  1bit(符号位) 8bits(指数位) 23bits(尾数位)
  double:
  1bit(符号位) 11bits(指数位) 52bits(尾数位)
  于是,float的指数范围为-127~+128,而double的指数范围为-1023~+1024

s=1*2+2*3+3*4+...+n*(n+1)=n*(n+1)*(n+2)/3;
=>> 对于 i*(i+1) 的前n项和,可以拆分成: i^2,i ,分别求前n项和

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-1178-Heritage from father【科学计数法表示】

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/47008491

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!