码迷,mamicode.com
首页 > 其他好文 > 详细

04-树5. File Transfer (25)

时间:2015-07-22 22:44:26      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:浙大pat   mooc   c语言实现   数据结构   不相交集   

04-树5. File Transfer (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2<=N<=104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:
no
no
yes
There are 2 components.
Sample Input 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:
no
no
yes
yes
The network is connected.

#include <stdio.h>
#include <stdlib.h>
int findSet(int *set, int val) {		//返回所在树的根节点
	while (set[val] >= 0) {
		val = set[val];
	}
	return val;
}
void unionSet(int *set, int c1, int c2) {	//按大小求并
	int root1 = findSet(set, c1);
	int root2 = findSet(set, c2);
	if (set[root1] < set[root2]) {	//树1更大,将树2连接到树1根节点
		set[root1] += set[root2];
		set[root2] = root1;
	}
	else {
		set[root2] += set[root1];
		set[root1] = root2;
	}
}
int main() {
//	freopen("test.txt", "r", stdin);
	int n;
	scanf("%d", &n);
	int *set = (int *)malloc(sizeof(int) * (n + 1));
	for (int i = 0; i <= n; ++i) {	//初始化树大小,根节点负值,其绝对值表示树大小
		set[i] = -1;
	}
	char ch;
	scanf("\n%c", &ch);
	while (ch != 'S') {
		int c1, c2;
		scanf("%d%d", &c1, &c2);
		if (ch == 'I') {
			unionSet(set, c1, c2);		//c1,c2所在集合求并
		}
		else if(ch == 'C') {
			if (findSet(set, c1) == findSet(set, c2)) {
				printf("yes\n");
			}
			else {
				printf("no\n");
			}
		}
		scanf("\n%c", &ch);
	}
	int cnt = 0;
	for (int i = 1; i <= n; ++i) {		//计算根节点个数
		if (set[i] < 0) {
			++cnt;
		}
	}
	if (cnt == 1) {
		printf("The network is connected.\n");
	}
	else {
		printf("There are %d components.\n", cnt);
	}
	free(set);

	return 0;
}


题目链接:http://www.patest.cn/contests/mooc-ds/04-%E6%A0%915

版权声明:本文为博主原创文章,未经博主允许不得转载。

04-树5. File Transfer (25)

标签:浙大pat   mooc   c语言实现   数据结构   不相交集   

原文地址:http://blog.csdn.net/ice_camel/article/details/47011127

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!