码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3203 Light Bulb(公式推导|三分法)(简单)

时间:2015-07-23 19:56:07      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:zoj   三分   公式推导   

Light Bulb

Time Limit: 1 Second      Memory Limit: 32768 KB

Compared to wildleopard‘s wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

技术分享

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard‘s shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750

4.000

公式推导:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
    int T;
    double H,h,D;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf",&H,&h,&D);
        double temp=sqrt((H-h)*D);
        double temp2=(H-h)*D/H;
        if(temp>=D)printf("%.3lf\n",h);
        else if(temp<temp2)printf("%.3lf\n",h*D/H);
        else
        {
            double ans=D+H-temp-(H-h)*D/temp;
            printf("%.3lf\n",ans);
        }
    }
    return 0;
}

三分法:

#include<iostream>
#include<cstdio>
using namespace std;
const double eps=1e-9;
double H,h,D;

double getL(double x)
{
    return D-x+H-(H-h)*D/x;
}

void search()
{
    double mid,midmid;
    double l=((H-h)*D)/H,r=D;
    while(r-l>eps)
    {
        mid=(l+r)/2;
        midmid=(mid+r)/2;
        if(getL(mid)<getL(midmid))
            l=mid;
        else
            r=midmid;
    }
    printf("%.3lf\n",getL(l));
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>H>>h>>D;
        search();
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

zoj 3203 Light Bulb(公式推导|三分法)(简单)

标签:zoj   三分   公式推导   

原文地址:http://blog.csdn.net/kaisa158/article/details/47026767

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!