码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 5305 Friends 暴力枚举

时间:2015-07-23 19:56:48      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:


暴力枚举边的状态.....

Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 120    Accepted Submission(s): 39


Problem Description
There are n people and m pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these n people wants to have the same number of online and offline friends (i.e. If one person has x onine friends, he or she must have x offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 
 

Input
The first line of the input is a single integer T (T=100), indicating the number of testcases. 

For each testcase, the first line contains two integers n (1n8) and m (0mn(n?1)2), indicating the number of people and the number of pairs of friends, respectively. Each of the next m lines contains two numbers x and y, which mean x and y are friends. It is guaranteed that xy and every friend relationship will appear at most once. 
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
0 2
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5309 5307 5306 5304 5303 
 


/* ***********************************************
Author        :CKboss
Created Time  :2015年07月23日 星期四 12时45分03秒
File Name     :1006.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

vector<int> G[10];

/// 1      0
int on[10],off[10];
int du[10];

int n,m;
int color[10][10];

int ans;

void init()
{
    for(int i=0;i<=n;i++) 
    {
        G[i].clear(); 
        on[i]=off[i]=0;
        du[i]=0;
    }
    ans=0;
    memset(color,-1,sizeof(color));
}



void dfs(int u)
{
    if(u==n+1) 
    {
        int fg=1;
        for(int i=1;i<=n&&fg;i++) { if(on[i]!=off[i]) fg=0; }
        ans+=fg;
        return ;
    }

    vector<int> vi;
    for(int i=0;i<du[u];i++)
    {
        int v=G[u][i];
        if(color[u][v]!=-1) continue;
        vi.push_back(v);
    }

    int nt=vi.size();

    for(int i=0;i<(1<<nt);i++)
    {
        for(int j=0;j<nt;j++)
        {
            int v=vi[j];
            int cc=(i&(1<<j));

            if(cc) cc=1;
            color[u][v]=cc;
            color[v][u]=cc;

            if(cc==0)
            {
                off[u]++; off[v]++;
            }
            else
            {
                on[u]++; on[v]++;
            }
        }

        if(on[u]==off[u]) dfs(u+1);

        /// uncolor

        for(int j=0;j<nt;j++)
        {
            int v=vi[j];
            int cc=(i&(1<<j));
            if(cc) cc=1;

            color[u][v]=-1;
            color[v][u]=-1;


            if(cc==0)
            {
                off[u]--; off[v]--;
            }
            else
            {
                on[u]--; on[v]--;
            }
        }
    }
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%d%d",&n,&m);
        init();
        for(int i=0,u,v;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            G[u].push_back(v); G[v].push_back(u);
        }
        bool flag=true;
        for(int i=1;i<=n&&flag;i++)
        {
            du[i]=G[i].size();
            if(du[i]%2) flag=false;
        }
        if(flag)
        {
            dfs(1);
            printf("%d\n",ans);
        }
        else
        {
            printf("%d\n",0);
        }
    }
    
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

HDOJ 5305 Friends 暴力枚举

标签:

原文地址:http://blog.csdn.net/ck_boss/article/details/47026765

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!