码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4004 The Frog's Games 【二分】

时间:2015-07-23 21:49:11      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:

The Frog‘s Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 4565    Accepted Submission(s): 2225


Problem Description
The annual Games in frogs‘ kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog‘s longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog‘s ability at least they should have.
 

Sample Input
6 1 2 2 25 3 3 11 2 18
 

Sample Output
4 11
 

根据题意很容易知道解的单调性,我们只需要对最远跳跃距离在 [0,L]范围内进行二分即可。技术分享

#include <queue>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 500000+5;
const int INF = 1000000000+5;
int L,n,m;
int stone[maxn];
bool judge(const int& x) {
    if(x*m < L) return false;
    if(x >= L) return true;
    for(int i = 0;i <= n+1;i++)
        if(i!=n+1&&stone[i+1]-stone[i] > x) return false;
    int step = 0;
    for(int i = 0,j;i < n+1;)
    {
        for(j = i+1;j <= n+1 && stone[j]-stone[i] <= x;)   //求当前解下需要最少的步数
            if(j+1 <= n+1 && stone[j+1]-stone[i] <= x) j++;
            else break;
        i = j;
        step++;
    }
    return step <= m;
}
int main() {
    //freopen("input.in","r",stdin);
    while(~scanf("%d %d %d",&L,&n,&m))
    {
        stone[0] = 0;
        for(int i = 1;i <= n;i++) scanf("%d",&stone[i]);
        sort(stone+1,stone+n+1);
        stone[n+1] = L;
        int l = 0,r = L+1,mid;
        while(r-l>=1)
        {
            mid = l+((r-l)>>1);
            if(judge(mid))  r = mid;
            else l = mid+1;
        }
        printf("%d\n",l);
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 4004 The Frog's Games 【二分】

标签:

原文地址:http://blog.csdn.net/acmore_xiong/article/details/47028887

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!