码迷,mamicode.com
首页 > 其他好文 > 详细

Toxophily-数论以及二分三分

时间:2015-07-23 23:55:22      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:

G - Toxophily
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on. 
We all like toxophily. 

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him? 

Now given the object‘s coordinates, please calculate the angle between the arrow and x-axis at Bob‘s point. Assume that g=9.8N/m. 
 

Input

The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow‘s exit speed. 
Technical Specification 

1. T ≤ 100. 
2. 0 ≤ x, y, v ≤ 10000. 
 

Output

For each test case, output the smallest answer rounded to six fractional digits on a separated line. 
Output "-1", if there‘s no possible answer. 

Please use radian as unit. 
 

Sample Input

3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
 

Sample Output

1.561582 -1 -1
 
现在只用公式算出,二分三分没有尝试,解出来了便会上传
公式法:

有题目可以知道:x,y,v都是已知条件
设vx=v*cos(α),vy=v*sin(α),同时从P(0,0)点到达目标点花了t时间,重力加速度为G=9.8.
∴x=vx*t,y=vy*t-1/2*G*t2.
消掉vx,vy,t可以转换为y=v*sin(α)*x/cos(α)-1/2*g*x2/(v2*cos(α)2).
∴将sin(α)/cos(α)=tan(α);
∴y=v*x*tan(α)-(1/2*g*x2/v2)*((sin(α)2+cos(α)2)/cos(α)2);
∴y=v*x*tan(α)-(1/2*g*x2/v2)*(1+tan(α)2);
∴将其进行整理可以得到:g*x2*tan(α)2-2*v2*x*tan(α)+2*v2y+g*x2=0;
∴可以得到△=b2-4*a*c;
∴令a=g*x2,b=-2*v2*x,c=2*v2y+g*x2.
又∵x1=(-b+(b2-4*a*c)?)/(2*a),x2=(-b-(b2-4*a*c)?)/(2*a).
∴可以通过上述公式将tan(α)求出,然后就是通过atan((tan(α)))将α求出
接着检查α是否符合条件就可以了。
/*
Author: 2486
Memory: 1616 KB		Time: 0 MS
Language: C++		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const double PI=acos(-1);
const double G=9.8;
int T;
double x,y,v;
int main() {
    scanf("%d",&T);
    while(T--) {
        scanf("%lf%lf%lf",&x,&y,&v);
        double a=G*x*x,b=-2.0*v*v*x,c=2.0*v*v*y+G*x*x;
        double posi=(-b+sqrt(b*b-4.0*a*c))/2.0/a;
        double ne=(-b-sqrt(b*b-4.0*a*c))/2.0/a;
        posi=atan(posi),ne=atan(ne);
        if(posi>=0&&posi<=PI/2.0&&ne>=0&&ne<=PI/2.0) {
            printf("%.6lf\n",posi>ne?ne:posi);
        } else if(ne>=0&&ne<=PI/2.0) {
            printf("%.6lf\n",ne);
        } else if(posi>=0&&posi<=PI/2.0) {
            printf("%.6lf\n",posi);
        } else printf("-1\n");
    }
    return 0;
}

三分二分方法
/*
Author: 2486
Memory: 1628 KB		Time: 0 MS
Language: C++		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const double PI=acos(-1);
const double eps=1e-10;
int T;
double x,y,v;
double C(double m) {
    double vx=v*cos(m),vy=v*sin(m);
    return (vy*x)/vx-9.8*(x/vx*x/vx)/2.0;
}
bool B(double m) {
    double vx=v*cos(m),vy=v*sin(m);
    return (vy*x)/vx-9.8*(x/vx*x/vx)/2.0>=y;
}
int main() {
    scanf("%d",&T);
    while(T--) {
        scanf("%lf%lf%lf",&x,&y,&v);
        double lb=0,ub=PI/2.0;
        ///////////////求出最大高度所对应的倾斜度////////////////
        while(ub-lb>eps) {
            double mid=(ub+lb)/2.0;
            double mmid=(ub+mid)/2.0;
            if(C(mid)>C(mmid)) {
                ub=mmid;
            } else lb=mid;
        }
        if(C(ub)<y) {
            printf("-1\n");
            continue;
        }
        ///////////////////////////////
        lb=0;
        ////////////////求出无限接近目标的倾斜度///////////////
        while(ub-lb>eps) {
            double mid=(ub+lb)/2.0;
            if(B(mid)) {
                ub=mid;
            } else lb=mid;
        }
        ///////////////////////////////
        printf("%.6lf\n",ub);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Toxophily-数论以及二分三分

标签:

原文地址:http://blog.csdn.net/qq_18661257/article/details/47029461

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!