码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5305 Friends(2015多校第二场 dfs + 剪枝)

时间:2015-07-24 10:54:46      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:

Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 552    Accepted Submission(s): 253


Problem Description
There are 技术分享 people and 技术分享 pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these 技术分享 people wants to have the same number of online and offline friends (i.e. If one person has 技术分享 onine friends, he or she must have 技术分享 offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 
 

Input
The first line of the input is a single integer 技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享, indicating the number of testcases. 

For each testcase, the first line contains two integers 技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享 and 技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享, indicating the number of people and the number of pairs of friends, respectively. Each of the next 技术分享 lines contains two numbers 技术分享 and 技术分享, which mean 技术分享 and 技术分享 are friends. It is guaranteed that 技术分享技术分享技术分享 and every friend relationship will appear at most once. 
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
0 2
 

Source
解题思路:
注意到数据范围很小,因此,暴力搜索+ 剪枝即可。
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXN = 30;
int x[MAXN],y[MAXN], s[MAXN], s1[MAXN], s2[MAXN], g[MAXN][MAXN];
int n, m;
int ans;
void dfs(int dep)
{
    if(dep > m)
    {
        for(int i=1;i<=n;i++)
        {
            if(s1[i] != s2[i])
                return ;
        }
        ans++;
        return ;
    }
    int u = x[dep], v = y[dep];
    if(s1[u] < s[u] / 2 && s1[v] < s[v] / 2)
    {
        s1[u]++; s1[v]++;
        dfs(dep + 1);
        s1[u]--; s1[v]--;
    }
    if(s2[u] < s[u] / 2 && s2[v] < s[v] / 2)
    {
        s2[u]++; s2[v]++;
        dfs(dep + 1);
        s2[u]--; s2[v]--;
    }
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &n, &m);
        memset(g, 0, sizeof(g));
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d", &x[i], &y[i]);
            g[x[i]][y[i]] = g[y[i]][x[i]] = 1;
        }
        int flag = 1;
        for(int i=1; i<=n; i++)
        {
            s[i] = s1[i] = s2[i] = 0;
            for(int j=1; j<=n; j++)
            {
                if(i != j && g[i][j] == 1)
                    s[i]++;
            }
            if(s[i] & 1) flag = 0;
        }
        if(!flag)
        {
            printf("0\n");
            continue;
        }
        ans = 0;
        dfs(1);
        printf("%d\n", ans);
    }
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5305 Friends(2015多校第二场 dfs + 剪枝)

标签:

原文地址:http://blog.csdn.net/moguxiaozhe/article/details/47035951

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!