码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-1102-Constructing Roads【最小生成树】

时间:2015-07-24 13:02:05      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16579 Accepted Submission(s): 6312


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2

Sample Output
179

Source

Recommend
Eddy | We have carefully selected several similar problems for you: 1301 1325 1217 3371 1874

#include<stdio.h> 
#include<string.h>
#include<algorithm>
using namespace std;
struct graph{
	int a,b;
	int dis;
}G[10010];
int root[110];
int tp;
int cmp(graph u,graph v){
	return u.dis<v.dis;
}
int  findset(int x){
	if(root[x]==x) return x;
	return root[x]=findset(root[x]);
}
void unio(int i,int j){
	int x,y;
	x=findset(i);
	y=findset(j);
	if(x<=y) root[y]=x;
	else root[x]=y;
	return;
}
void kruskal(){
    sort(G,G+tp,cmp);
    int shortest=0;
    for(int i=0;i<tp;++i){
    	int t,k;
    	t=findset(G[i].a);
    	k=findset(G[i].b);
    	if(t!=k){
    		shortest+=G[i].dis;
    		unio(t,k);
    	}
    }
    printf("%d\n",shortest);
    return ; 
}
int main(){
	int n;
	while(~scanf("%d",&n)){
		memset(G,0,sizeof(G));
		int i,j,q,aa,bb,d;
		tp=0;
		for(i=1;i<=n;++i) root[i]=i;
		for(i=1;i<=n;++i){
			for(j=1;j<=n;++j){
				scanf("%d",&d);
				G[tp].a=i;
				G[tp].b=j;
				G[tp].dis=d;
				++tp;
				
			}
		}
		scanf("%d",&q);
		while(q--){
			scanf("%d%d",&aa,&bb);
			unio(aa,bb);
		}
		kruskal();
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-1102-Constructing Roads【最小生成树】

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/47037211

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!