码迷,mamicode.com
首页 > 其他好文 > 详细

uva624 CD (01背包+路径的输出)

时间:2015-07-24 14:22:05      阅读:87      评论:0      收藏:0      [点我收藏+]

标签:uva348   uva   

CD
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Submit Status Practice UVA 624
Appoint description:

Description
Download as PDF

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.

Assumptions:

number of tracks on the CD. does not exceed 20
no track is longer than N minutes
tracks do not repeat
length of each track is expressed as an integer number
N is also integer 

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

Input
Any number of lines. Each one contains value N, (after space) number of tracks and durations of the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

Output
Set of tracks (and durations) which are the correct solutions and string “ sum:” and sum of duration times.

Sample Input

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2

Sample Output

1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45

Miguel A. Revilla
2000-01-10

//把题目转化为背包问题,即选择尽量多的CD曲子去装满这个时间区间
#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<stack>
#include<string>
#include<fstream>
#define pb(s) push_back(s)
#define cl(a,b) memset(a,b,sizeof(a))
#define bug printf("===\n");
using namespace std;
typedef vector<int> VI;
#define rep(a,b) for(int i=a;i<b;i++)
#define rep_(a,b) for(int i=a;i<=b;i++)
#define P pair<int,int>
#define bug printf("===\n");
#define PL(x) push_back(x)
#define X first
#define Y second
#define vi vector<int>
#define rep(i,x,n) for(int i=x;i<n;i++)
#define rep_(i,x,n) for(int i=x;i<=n;i++)
const int maxn=15000;
const int inf=999999999;
typedef long long LL;
int a[maxn];
int dp[maxn];
int f[maxn][maxn];
int cnt;
int ans[maxn];
void print(int n,int m){//是dp的逆过程,递归回去
    if(m==0)return ;
    if(f[m][n]){
        print(n-a[m],m-1);
        ans[cnt++]=a[m];
    }
    else {
        print(n,m-1);
    }
}
int main(){
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        for(int i=1;i<=m;i++){
            scanf("%d",&a[i]);
        }
       for(int i=0;i<=n;i++){
            dp[i]=0;
            for(int j=0;j<=n;j++){
                f[i][j]=0;
            }
       }
        for(int i=1;i<=m;i++){
            for(int j=n;j>=a[i];j--){
                dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
                if(dp[j]==dp[j-a[i]]+a[i]){
                    f[i][j]=1;
                }
            }
        }
        cnt=0;
        print(n,m);
        for(int i=0;i<cnt;i++){
            printf("%d ",ans[i] );
        }
        printf("sum:%d\n",dp[n]);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

uva624 CD (01背包+路径的输出)

标签:uva348   uva   

原文地址:http://blog.csdn.net/u013167299/article/details/47040085

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!