码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1879 继续畅通工程(最小生成树)

时间:2015-07-24 18:22:53      阅读:85      评论:0      收藏:0      [点我收藏+]

标签:hdu1879   hdu 1879   畅通工程   最小生成树   

继续畅通工程

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17319    Accepted Submission(s): 7445


Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。
 

Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
 

Sample Input
3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
 

Sample Output
3 1 0
 

Author
ZJU
 

Source
 

Recommend
We have carefully selected several similar problems for you:  1102 1856 1301 1162 1325 
 

Statistic | Submit | Discuss | Note

畅通工程系列是做完了~~

最小生成树~两种算法prim和kruskal。我应用的后者

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
int fa[105];
struct node
{
    int a,b,cost;
}c[5000];
bool cmp(node x,node y)
{
    return x.cost<y.cost;
}
int find(int x)
{
    if(fa[x]!=x) fa[x]=find(fa[x]);
    return fa[x];
}
int main()
{
    int n,x;
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(&c,0,sizeof(&c));
        for(int i=1;i<=n;i++)
        fa[i]=i;
        n=n*(n-1)/2;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d %d %d",&c[i].a,&c[i].b,&c[i].cost,&x);
            if(x==1)
            c[i].cost=0;
        }
        sort(c,c+n,cmp);
        int sum=0;
        for(int i=0;i<n;i++)
        {
            int x=find(c[i].a);
            int y=find(c[i].b);
            if(x!=y)
            fa[x]=y,sum+=c[i].cost;
        }
        printf("%d\n",sum);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu1879 继续畅通工程(最小生成树)

标签:hdu1879   hdu 1879   畅通工程   最小生成树   

原文地址:http://blog.csdn.net/su20145104009/article/details/47027605

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!