码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3252 Round Numbers(数位dp)

时间:2015-07-24 18:34:45      阅读:105      评论:0      收藏:0      [点我收藏+]

标签:dp

Language:
Round Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10233   Accepted: 3734

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone‘ (also known as ‘Rock, Paper, Scissors‘, ‘Ro, Sham, Bo‘, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can‘t even flip a coin because it‘s so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

Source



/*
题意:求一个区间内数的二进制数的0的数目大于1的数目的数的个数
思路:数位dp,dp[i][j][k] 代表i位置 已经出现j个1 k个0
     具体细节在代码中写出

*/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define bug printf("hihi\n")

#define eps 1e-8
typedef __int64 ll;

using namespace std;


#define INF 0x3f3f3f3f
#define N 35

int dp[35][35][35];

int bit[N];

int dfs(int pos,int st,int le,int ri,bool bound) //st为当前状态前面是否出现了1
{
    if(pos==0) return ri>=le&&st ? 1:0;

    if(!bound&&st&&dp[pos][le][ri]>=0) return dp[pos][le][ri];

    int up=bound ? bit[pos]:1;
    int ans=0;
    for(int i=0;i<=up;i++)
        if(i==0)
          ans+=dfs(pos-1,st,le,st? ri+1:0,bound&&i==up);
    else                         //如果前面都没有出现1,那么前面出现的0都是无效的
          ans+=dfs(pos-1,1,le+1,ri,bound&&i==up);

    if(!bound&&st) dp[pos][le][ri]=ans;
    return ans;
}

int solve(int x)
{
    int i,j;
    int len=0;
    while(x)
    {
        bit[++len]=x%2;
        x/=2;
    }
    return dfs(len,0,0,0,true);
}

int main()
{
   int i,j;
   int le,ri;
   memset(dp,-1,sizeof(dp));
   while(~scanf("%d%d",&le,&ri))
   {
       printf("%d\n",(solve(ri)-solve(le-1)));
   }
   return 0;
}





版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 3252 Round Numbers(数位dp)

标签:dp

原文地址:http://blog.csdn.net/u014737310/article/details/47042505

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!