码迷,mamicode.com
首页 > 其他好文 > 详细

BFS,推荐

时间:2015-07-24 22:17:15      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

技术分享
 

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

 

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

 

Output Specification

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

 

Sample Input

 

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

 

Sample Output

 

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

程序代码:

#include<stdio.h>
技术分享#define max 1000000
技术分享技术分享int Map[8][2] = 技术分享{技术分享{-2, 1}, 技术分享{-1, 2}, 技术分享{1, 2}, 技术分享{2, 1}, 技术分享{2, -1}, 技术分享{1, -2}, 技术分享{-1, -2}, 技术分享{-2, -1}};
技术分享//这里将数组代替队列,如果需要,可以变通为滚动数组,当下标达到极限时在置为0 
技术分享struct N
技术分享技术分享技术分享{
技术分享    int r, c, k;
技术分享}N[max];
技术分享int s[9][9];
技术分享int Find()
技术分享技术分享技术分享{    
技术分享    int k, h, j, i, x, y;
技术分享    h = 0;
技术分享    j = 1;
技术分享    x = N[h].r;
技术分享    y = N[h].c;    
技术分享    if (s[x][y] == 2)
技术分享技术分享    技术分享{
技术分享        return N[h].k;
技术分享    }
技术分享    while (1)
技术分享技术分享    技术分享{            
技术分享        for (i = 0; i < 8; i++)
技术分享技术分享        技术分享{
技术分享            x = N[h].r + Map[i][0];
技术分享            y = N[h].c + Map[i][1];
技术分享            if (x >= 0 && x < 8 && y >=0 && y < 8)
技术分享技术分享            技术分享{
技术分享                if (s[x][y] == 2)
技术分享技术分享                技术分享{
技术分享                    return N[h].k + 1;
技术分享                }
技术分享                else if (s[x][y] == 0)
技术分享技术分享                技术分享{
技术分享                    N[j].r = x;    
技术分享                    N[j].c = y;
技术分享                    s[x][y] = 1;// 将被扫过的点置为1,我因检查少写了该句被RE了n次 
技术分享                    N[j].k = N[h].k + 1;
技术分享                    j++;
技术分享                }
技术分享            }    
技术分享        }
技术分享        h++;
技术分享    }
技术分享};
技术分享int main()
技术分享技术分享技术分享{
技术分享    char ch[2][5];
技术分享    int i, j, l1, l2, k, r1, r2;
技术分享    while (scanf("%s %s", ch[0], ch[1]) != EOF)
技术分享技术分享    技术分享{
技术分享        for (i = 0; i < 8; i++)
技术分享技术分享        技术分享{
技术分享            for(j = 0; j < 8; j++)
技术分享技术分享            技术分享{
技术分享                s[i][j] = 0;
技术分享            }
技术分享        }
技术分享        //将输入的点转为一个二维数组的下标 
技术分享        l1 = ch[0][0] - ‘a‘;
技术分享        l2 = ch[1][0] - ‘a‘;
技术分享        r1 = ch[0][1] - ‘1‘;
技术分享        r2 = ch[1][1] - ‘1‘;
技术分享        s[r1][l1] = 1;//1 表示起点 
技术分享        s[r2][l2] = 2;//2 表示终点 
技术分享        N[0].r = r1;
技术分享        N[0].c = l1;
技术分享        N[0].k = 0;    //k 用于记录当前广度(层数) 
技术分享        k = Find();
技术分享        printf("To get from %s to %s takes %d knight moves.\n", ch[0], ch[1], k);                    
技术分享    }
技术分享    system("pause");
技术分享    return 0;
技术分享}

BFS,推荐

标签:

原文地址:http://www.cnblogs.com/yilihua/p/4674702.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!