码迷,mamicode.com
首页 > 其他好文 > 详细

二叉树遍历,推荐

时间:2015-07-24 22:23:44      阅读:98      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

技术分享
 

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

 

                                    D
                                   /                                   /                                    B     E
                                / \                                    /   \     \ 
                              A     C     G
                                         /
                                        /
                                       F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

 


Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

 

Input Specification 

The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

 

Output Specification 

For each test case, recover Valentine‘s binary tree and print one line containing the tree‘s postorder traversal (left subtree, right subtree, root).

 

Sample Input 

DBACEGF ABCDEFG
BCAD CBAD

 

Sample Output 

ACBFGED
CDAB

程序分析:骑士走日,和中国象棋中的马一样走日。(使用广搜BFS)

程序代码:

#include <iostream>
#include <queue>
#include<string.h>
using namespace std;
int s1,s2,e1,e2;
int tu[8][8];
int xx[8] = {1, 2, 1, 2, -1, -2, -1, -2};//x坐标变化
int yy[8] = {2, 1, -2, -1, 2, 1, -2, -1};//y坐标变化
int bfs()
{
    memset(tu,0,sizeof(tu));//数组值全为0
    queue<int> q;
    int x1,y1,x2,y2;
    tu[s1][s2]=0;//
    q.push(s1);
    q.push(s2);
    while(!q.empty())
    {
        x1=q.front();
        q.pop();
        y1=q.front();
        q.pop();
        if(x1==e1&&y1==e2)//在原地不动
            return tu[x1][y1];
        for(int i=0; i<8; i++)
        {
            x2=x1+xx[i];
            y2=y1+yy[i];
            if(x2<0||x2>7||y2<0||y2>7||tu[x2][y2]>0)
                continue;
            tu[x2][y2]=tu[x1][y1]+1;
            q.push(x2);
            q.push(y2);
        }
    }
    return 0;
}
int main()
{
    char a[3],b[3];
    int total;
    while(cin>>a>>b)
    {
        s1=a[0]-a;//输入的字母,是列,从第一列a开始,减去‘a‘,转换
        s2=a[1]-1;//输入的数字,是行,从的第一行开始,减去‘1‘,转换
        e1=b[0]-a;
        e2=b[1]-1;
        total=bfs();
        cout<<"To get from "<<a<<" to "<<b<<" takes "<<total<<" knight moves."<<endl;
    }
    return 0;
}

 

二叉树遍历,推荐

标签:

原文地址:http://www.cnblogs.com/yilihua/p/4674699.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!