码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3273 Monthly Expense(二分)

时间:2015-07-24 22:46:13      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:

Monthly Expense
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 17465   Accepted: 6961

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ‘s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source



   题意:有n份钱,要求分成m组,并且一份不许拆分,要求分成的m组后每一组总的和最小,然后输出这种情况下最大一组的和。

   看懂题后想不出来用二分写,还是做得题少......

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int n,m;
int num[1000100];
int l,r;

int qurry(int mid)
{
    int p = 1;
    int sum = 0;
    for(int i=0;i<n;i++)
    {
        if((sum+num[i])<=mid)
        {
            sum += num[i];
        }
        else
        {
            sum = num[i];
            p++;
        }
    }
    if(p>m)
    {
        return 0;
    }
    return 1;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        l = 0;
        r = 0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&num[i]);
            r += num[i];
            if(l<num[i])
            {
                l = num[i];
            }
        }
        int mid = (l+r)/2;
        while(l<r)
        {
            if(qurry(mid))
            {
                r = mid - 1;
            }
            else
            {
                l = mid + 1;
            }
            mid = (l+r)/2;
        }
        printf("%d\n",mid);
    }
    return 0;
}


版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

POJ 3273 Monthly Expense(二分)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/47046881

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!