码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3122 Pie(简单二分)

时间:2015-07-25 10:48:15      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:

Pie
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12486   Accepted: 4310   Special Judge

Description

技术分享My birthday is coming up and traditionally I‘m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10?3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source




         题意:主人过生日,m个人来庆生,所以n块蛋糕,m+1个人(还有主人自己)分,问每个人分到的最大体积的蛋糕是多大,PS每 个人所分的蛋糕必须是在同一个蛋糕上写下来的。



#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
using namespace std;

const double PI = 3.14159265359;
const double eps = 1e-7;
double pie[100010];
int n,m;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        double maxx = 0;
        for(int i=0;i<n;i++)
        {
            scanf("%lf",&pie[i]);
            pie[i] *= pie[i];
            if(maxx<pie[i])
            {
                maxx = pie[i];
            }
        }
        m  = m + 1;
        double l = 0;
        double r = maxx;
        double mid;
        while(r-l>eps)
        {
            mid = (r+l)/2;
            int sum = 0;
            for(int i=0;i<n;i++)
            {
                if(pie[i]-mid>eps)
                {
                    sum += (int)pie[i]/mid;
                }
            }
            if(sum>=m)
            {
                l = mid;
            }
            else
            {
                r = mid;
            }
        }
        printf("%.4lf\n",mid*PI);
    }
    return 0;
}


版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

POJ 3122 Pie(简单二分)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/47053045

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!