码迷,mamicode.com
首页 > 其他好文 > 详细

hdojText Reverse

时间:2015-07-25 12:22:02      阅读:105      评论:0      收藏:0      [点我收藏+]

标签:



/*Text Reverse
Problem Description
Ignatius likes to write words in reverse way.
Given a single line of text which is written by Ignatius,
you should reverse all the words and then output them.

Input
The input contains several test cases.
The first line of the input is a single integer T which is the number of test cases.
T test cases follow.
Each test case contains a single line with several words.
There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m‘I morf .udh
I ekil .mca
Sample Output

hello world!
I‘m from hdu.
I like acm.*/

<span style="font-size:18px;">#include <stdio.h>
#include <string.h>
int main()
{
 int i,j,len,t;
 char a[1002];
 scanf("%d\n",&t);
 while(t--)
 {
  gets(a);
  len = strlen(a);
  for(i=0;i<len;i++)
  {
   if((i-1>=0&&a[i-1]!=' '&&a[i]==' ')||i==len-1)
   {
    if(i==len-1)
    {
     if(a[i]!=' ') j=i;
     else  j=i-1;
    }else j=i-1;
    while(1)
    {
     if(j<0||a[j]==' ') break;
     printf("%c",a[j--]);
    }
    if(a[i]==' ') printf(" ");
   }else if(a[i]==' ') 
   {
    printf(" ");
   }
  }
  printf("\n");
 }
 return 0;
}</span>

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdojText Reverse

标签:

原文地址:http://blog.csdn.net/qjt19950610/article/details/47054649

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!