码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2823 单调队列 deque写法

时间:2015-07-25 12:25:13      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:acm   poj   

Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 46435   Accepted: 13417
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

POJ Monthly--2006.04.28, Ikki

#include <iostream>
#include <cstdio>
#include <queue>
#include <deque>

using namespace std;
typedef pair<int, int> P;
#define maxn 1000000 + 10

deque<P> Q1;
deque<P> Q2;
int n, k;
int Min[maxn], Max[maxn];

int main()
{
    while(~scanf("%d%d", &n, &k))
    {
        while(!Q1.empty()) Q1.pop_back();
        while(!Q2.empty()) Q2.pop_back();
        int x;
        for(int i=1; i<=n; i++)
        {
            scanf("%d", &x);
            while(!Q1.empty() && Q1.back().first >= x) Q1.pop_back();
            Q1.push_back(P(x, i));
            if(i >= k)
                {
                    while(!Q1.empty() && Q1.front().second <= i-k) Q1.pop_front();
                    Min[i] = Q1.front().first;
                }

            while(!Q2.empty() && Q2.back().first <= x) Q2.pop_back();
            Q2.push_back(P(x, i));
            if(i >= k)
                {
                    while(!Q2.empty() && Q2.front().second <= i-k) Q2.pop_front();
                    Max[i] = Q2.front().first;
                }
        }

        for(int i=k; i<=n; i++)
            i == n ? printf("%d\n", Min[i]) : printf("%d ", Min[i]);

        for(int i=k; i<=n; i++)
            i == n ? printf("%d\n", Max[i]) : printf("%d ", Max[i]);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 2823 单调队列 deque写法

标签:acm   poj   

原文地址:http://blog.csdn.net/dojintian/article/details/47054589

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!