码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4771 Stealing Harry Potter's Precious (深搜+广搜)

时间:2015-07-25 12:23:55      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:区域赛   hdu   搜索   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4771


题面:


Stealing Harry Potter‘s Precious

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2207    Accepted Submission(s): 1035


Problem Description
  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon‘s home. But he can‘t bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:

技术分享


  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers‘ properties, so they live in the indestructible rooms and put customers‘ properties in vulnerable rooms. Harry Potter‘s precious are also put in some vulnerable rooms. Dudely wants to steal Harry‘s things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can‘t access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry‘s precious are. He wants to collect all Harry‘s precious by as less steps as possible. Moving from one room to another adjacent room is called a ‘step‘. Dudely doesn‘t want to get out of the bank before he collects all Harry‘s things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry‘s precious.
 

Input
  There are several test cases.
  In each test cases:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
  Then a N×M matrix follows. Each element is a letter standing for a room. ‘#‘ means a indestructible room, ‘.‘ means a vulnerable room, and the only ‘@‘ means the vulnerable room from which Dudely starts to move.
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter‘s precious in the bank.
  In next K lines, each line describes the position of a Harry Potter‘s precious by two integers X and Y, meaning that there is a precious in room (X,Y).
  The input ends with N = 0 and M = 0
 

Output
  For each test case, print the minimum number of steps Dudely must take. If Dudely can‘t get all Harry‘s things, print -1.
 

Sample Input
2 3 ##@ #.# 1 2 2 4 4 #@## .... #### .... 2 2 1 2 4 0 0
 

Sample Output
-1 5
 

Source


解题:

    首先找出,每两个点间的最短距离,然后由起点出发,算出由该点到达所有点的最短距离。写的比较复杂,可以稍加改进。

总结:

    深搜结束后,一定要注意状态的还原。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
char map[105][105];
bool visit[105][105],vis[5];
int n,m,q,fmx,fmy,tox,toy,x,y,len,tmp,ans,res;
int dis[5][5];
int desx[5],desy[5];
struct node
{
	int x,y,step;
};
queue <node> qe;
int bfs()
{
 while(!qe.empty())
	 qe.pop();
   node tmp;
   tmp.x=fmx;
   tmp.y=fmy;
   tmp.step=0;

   qe.push(tmp);
   memset(visit,-1,sizeof(visit));
   for(int i=0;i<=m+1;i++)
   {
	   visit[0][i]=visit[n+1][i]=0;
   }
   for(int i=1;i<=n;i++)
   {
	   visit[i][0]=visit[i][m+1]=0;
   }
   while(!qe.empty())
   {
	   tmp=qe.front();
	   qe.pop();
       x=tmp.x;
	   y=tmp.y;
	   len=tmp.step;
	   if(map[x][y]=='@')
	   {
		   return len;
	   }
	   else if(map[x][y]=='#')continue;
	   else if(map[x][y]=='.')
	   {
		   tmp.step=len+1;
		   if(visit[x-1][y])
		   {
			   tmp.x=x-1;
			   tmp.y=y;
			   qe.push(tmp);
			   visit[x-1][y]=0;

		   }
		   if(visit[x][y-1])
		   {
			   tmp.x=x;
			   tmp.y=y-1;
			   qe.push(tmp);
			   visit[x][y-1]=0;

		   }
		   if(visit[x][y+1])
		   {
			   tmp.x=x;
			   tmp.y=y+1;
			   qe.push(tmp);
			   visit[x][y+1]=0;
		   }
		   if(visit[x+1][y])
		   {
			   tmp.x=x+1;
			   tmp.y=y;
			   qe.push(tmp);
			   visit[x+1][y]=0;

		   }
	   }
   }
   return -1;
}
int dfs(int fx,int ty,int cnt)
{
   int temp,minn=999999999;
   vis[ty]=1;
   if(cnt==q)
   {
	   return dis[fx][ty];
   }
   for(int i=1;i<=q;i++)
   {
	   if(!vis[i])
	   {
		   temp=dfs(ty,i,cnt+1);
		  // printf("%d\n",temp);
		   minn=min(temp,minn);
		   vis[i]=0;
	   }
   }
    return dis[fx][ty]+minn;
}
int main()
{
   while(scanf("%d%d",&n,&m)&&(n||m))
   {
	   memset(dis,-1,sizeof(dis));
	   bool flag=true;
	   for(int i=1;i<=n;i++)
	   {
		   for(int j=1;j<=m;j++)
			   scanf(" %c",&map[i][j]);
	   }
	   scanf("%d",&q);
	   for(int i=1;i<=q;i++)
		   scanf("%d%d",&desx[i],&desy[i]);
	   for(int i=1;i<=n;i++)
	   {
		   for(int j=1;j<=m;j++)
			   if(map[i][j]=='@')
			   {
				   desx[0]=i;
				   desy[0]=j;
			   }
	   }
	   map[desx[0]][desy[0]]='.';
	   for(int i=0;i<q;i++)
	   {
		   for(int j=0;j<=q-1-i;j++)
		   {
			  fmx=desx[i];
			  fmy=desy[i];
			  tox=desx[i+j+1];
			  toy=desy[i+j+1];
			  map[tox][toy]='@';
              dis[i][j+i+1]=bfs();
			  map[tox][toy]='.';
		   }
	   }
	   for(int i=0;i<=q;i++)
	   {
		   for(int j=0;j<=q;j++)
		   {
			   tmp=max(dis[i][j],dis[j][i]);
			   dis[i][j]=dis[j][i]=tmp;
			   //printf("%d-%d: %d\n",i,j,dis[i][j]);
		   }
	   }
	   for(int i=0;i<=q;i++)
	   {
		   for(int j=0;j<=q;j++)
		   {
			   if(i!=j&&dis[i][j]==-1)
			   {
                 flag=false;
				 break;
			   }
		   }
	   }
	   if(!flag)
	   {
		   printf("-1\n");
		   continue;
	   }
	   ans=99999998;
	   //printf("**\n");
	   memset(vis,0,sizeof(vis));
	   for(int i=1;i<=q;i++)
	   {
		   ans=min(ans,dfs(0,i,1));
		   vis[i]=0;
	    }
	   //printf("***\n");
	   printf("%d\n",ans);
   }

	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 4771 Stealing Harry Potter's Precious (深搜+广搜)

标签:区域赛   hdu   搜索   

原文地址:http://blog.csdn.net/david_jett/article/details/47054513

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!