码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1712 分组背包 ACboy needs your help

时间:2015-07-25 18:16:12      阅读:102      评论:0      收藏:0      [点我收藏+]

标签:

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5022    Accepted Submission(s): 2714


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

 

Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

 

Sample Output
3 4 6
 

 

Source
 
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int a[200][200];
int f[1000];
int main(){
   int n,m;
   while(scanf("%d%d",&n,&m)!=EOF){
       if(n==0&&m==0)
       break;
    memset(f,0,sizeof(f));
       memset(a,0,sizeof(a));
       for(int i=1;i<=n;i++){
        for(int j=1;j<=m;j++)
            scanf("%d",&a[i][j]);
       }

       for(int i=1;i<=n;i++){
          for(int j=m;j>=0;j--){
            for(int k=1;k<=j;k++)
                f[j]=max(f[j],f[j-k]+a[i][k]);
          }
       }
       printf("%d\n",f[m]);
   }
   return 0;
}

 

hdu1712 分组背包 ACboy needs your help

标签:

原文地址:http://www.cnblogs.com/13224ACMer/p/4676274.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!