码迷,mamicode.com
首页 > 其他好文 > 详细

Common Subsequence-最长公共子序列

时间:2015-07-25 20:04:09      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:

B - Common Subsequence
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
二维代码:
/*
Author: 2486
Memory: 4108 KB		Time: 32 MS
Language: C++		Result: Accepted
*/
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=1000+5;
char str1[maxn],str2[maxn];
int dp[maxn][maxn];
int main() {
    while(~scanf("%s%s",str1+1,str2+1)) {
        int la=strlen(str1+1);
        int lb=strlen(str2+1);
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=la; i++) {
            for(int j=1; j<=lb; j++) {
                if(str1[i]==str2[j]) {
                    dp[i][j]=dp[i-1][j-1]+1;
                } else if(str1[i]!=str2[j]) {
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        printf("%d\n",dp[la][lb]);
    }

    return 0;
}

一维代码:
maxp记录没有进行变化的的最大数据
l记录着对应的数据信息

/*
Author: 2486
Memory: 728 KB		Time: 16 MS
Language: G++		Result: Accepted
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=10000+5;
int dp[maxn];
string ss,kk;
int main() {
    while(cin>>ss>>kk) {
        memset(dp,0,sizeof(dp));
        int l,maxp;
        if(ss.length()<kk.length())swap(ss,kk);
        for(int i=0; i<ss.length(); i++) {
            maxp=0;
            for(int j=0; j<kk.length(); j++) {
                l=dp[j];
                if(ss[i]==kk[j]&&dp[j]<maxp+1)dp[j]=maxp+1;
                maxp=max(maxp,l);
            }
        }
        int ans=0;
        for(int i=0;i<ss.length();i++){
            ans=max(ans,dp[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

Common Subsequence-最长公共子序列

标签:

原文地址:http://blog.csdn.net/qq_18661257/article/details/47058731

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!