码迷,mamicode.com
首页 > 其他好文 > 详细

【HDU2639】Bone Collector II(01背包第k优解)

时间:2015-07-25 21:38:02      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2948    Accepted Submission(s): 1526


Problem Description
The title of this problem is familiar,isn‘t it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven‘t seen it before,it doesn‘t matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 231).
 

Sample Input
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
12 2 0
 

大概就是求能装下的第k多的价值 

dp数组增加一维 作为第l多的价值 

dp[j][l]   dp[j-vo[i]][l] + va[i] 用数组a和b分别存下 之后放在一起判断大小排序 其他同01背包

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 1011;
int va[maxn], vo[maxn];
int n, v, k;
int dp[maxn][55];
int a[55], b[55];

int main(){
    int t;
    scanf("%d", &t);
    while(t--){
        scanf("%d%d%d", &n, &v, &k);
        for(int i = 1; i <= n; ++i){
            scanf("%d", &va[i]);
        }
        for(int i = 1; i <= n; ++i){
            scanf("%d", &vo[i]);
        }
        memset(dp, 0, sizeof(dp));

        for(int i = 1; i <= n; ++i){
            for(int j = v; j >= vo[i]; --j){
                for(int l = 1; l <= k; ++l){
                    a[l] = dp[j][l];
                    b[l] = dp[j-vo[i]][l] + va[i];
                }

                a[k+1] = b[k+1] = -1;
                int x = 1, y = 1, w = 1;
                while(w <= k && (x <= k || y <= k)){
                    if(a[x] > b[y]){
                        dp[j][w] = a[x++];
                    }
                    else{
                        dp[j][w] = b[y++];
                    }

                    if(w == 1 || dp[j][w] != dp[j][w-1]){
                        ++w;
                    }
                }
            }
        }

        printf("%d\n", dp[v][k]);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

【HDU2639】Bone Collector II(01背包第k优解)

标签:

原文地址:http://blog.csdn.net/u012431590/article/details/47059481

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!