码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1860 Currency Exchange (Bellman ford)

时间:2015-07-26 00:23:45      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:

Currency Exchange
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 22405   Accepted: 8095

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion
 
题意:给定M种货币,有N个兑换点,开始手中有的货币种类是S并且数量为V,问能否从起点出发经过货币的兑换后再回到起点时,货币S的数量会增加
用100A兑换B时,汇率为29.75,手续费为0.39,那么最后得到的B为(100 - 0.39) * 29.75 = 2963.39
分析:是否存在正权回路,使得回路上的顶点的权值能够不断进行松弛
采用Bellman ford算法
原本的Bellman ford算法可以判断是否存在负圈,那么这题就是反向运用Bellman ford
如果存在S到其他点的距离能够不断变大时,存在正权回路
初始化d[S]=V 而源点到其他点的距离初始化为无穷小(0)
技术分享
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
using namespace std;
const int MAXN=200+5;
int n,m,S,tot;
int MON[2][MAXN];
double RC[2][MAXN],d[MAXN],V;
bool flag;

bool Bellman()
{
    for(int i=1;i<=n;i++)
        d[i]=0;
    d[S]=V;
    for(int i=1;i<n;i++)
    {
        bool tg=false;
        for(int j=1;j<=tot;j++)
        {
            int u=MON[0][j];
            int v=MON[1][j];
            if(d[v]<(d[u]-RC[1][j])*RC[0][j])
            {
                d[v]=(d[u]-RC[1][j])*RC[0][j];
                tg=true;
            }
        }
        if(!tg) return false;
    }
    for(int i=1;i<=tot;i++)
    {
        int u=MON[0][i];
        int v=MON[1][i];
        if(d[v]<(d[u]-RC[1][i])*RC[0][i])
            return true;
    }
    return false;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d %d %d %lf",&n,&m,&S,&V)!=EOF)
    {
        tot=1;
        memset(MON,0,sizeof(MON));
        memset(RC,0,sizeof(RC));

        for(int i=0;i<m;i++)
        {
            int a,b;
            double c,d,e,f;
            scanf("%d %d %lf %lf %lf %lf",&a,&b,&c,&d,&e,&f);
            MON[0][tot]=a;
            MON[1][tot]=b;
            RC[0][tot]=c;
            RC[1][tot]=d;
            tot++;
            MON[0][tot]=b;
            MON[1][tot]=a;
            RC[0][tot]=e;
            RC[1][tot]=f;
            tot++;
        }

        if(Bellman()) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
View Code

 

POJ 1860 Currency Exchange (Bellman ford)

标签:

原文地址:http://www.cnblogs.com/clliff/p/4676844.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!