码迷,mamicode.com
首页 > 其他好文 > 详细

A Simple Task

时间:2015-07-26 12:27:58      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:

A Simple Task

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4313    Accepted Submission(s): 2372


Problem Description
Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.


Example

For n = 24, o = 3 and p = 3.


Task

Write a program which for each data set:

reads a positive integer n,

computes the odd integer o and the nonnegative integer p such that n = o2^p,

writes the result.
 

 

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
 

 

Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.
 

 

Sample Input
1
24
 

 

Sample Output
3 3
#include<stdio.h>
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int a,c=0;
        scanf("%d",&a);
        while(a%2==0)
        {
            c++;
            a/=2;
        }
        printf("%d %d\n",a,c);
    }
    
    return 0;
}

 

A Simple Task

标签:

原文地址:http://www.cnblogs.com/a1225234/p/4677422.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!