码迷,mamicode.com
首页 > 其他好文 > 详细

1058. A+B in Hogwarts (20)

时间:2015-07-26 12:39:03      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:pat   算法   进位   

题目如下:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it‘s easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28


设计一个结构体存储G、S、K三位,根据题目条件进位即可。

#include <iostream>
#include <stdio.h>

using namespace std;

struct GSK{
    int G;
    int S;
    int K;

    void add(GSK other){
        int carry;
        K += other.K;
        carry = K / 29;
        K = K % 29;
        S = S + carry + other.S;
        carry = S / 17;
        S = S % 17;
        G = G + carry + other.G;
    }

};

int main()
{
    GSK n1,n2;
    scanf("%d.%d.%d",&n1.G,&n1.S,&n1.K);
    scanf("%d.%d.%d",&n2.G,&n2.S,&n2.K);
    n1.add(n2);
    printf("%d.%d.%d",n1.G,n1.S,n1.K);
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

1058. A+B in Hogwarts (20)

标签:pat   算法   进位   

原文地址:http://blog.csdn.net/xyt8023y/article/details/47067023

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!