标签:想法题
Leftmost Digit
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 7 Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
Sample Output
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
题意:
给你一个数字n,输出n的n次的第一位。
题解:
n^n=n*log10(n)。而10的整数次方数的首位为1,因此要求此题的答案只需求出n*log10(n)的小数部分m,因为0<m<10,所以10^m的整数部分((int)pow(10,m))即为答案。
参考代码:
#include<stdio.h>
#include<math.h>
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
double a,c,n;
long long d,b;
scanf("%lf",&n);
a=n*log10(n);
b=(long long)a;//由于题目数据量的限制,这里的b的强制转换为long long型,int型会wa。
c=a-b;
d=(int)pow(10.0,c);
printf("%lld\n",d);
}
return 0;
}
HDU 1060 - Leftmost Digit
标签:想法题
原文地址:http://blog.csdn.net/luwhere/article/details/47066921