码迷,mamicode.com
首页 > 其他好文 > 详细

The broken pedometer-纯暴力枚举

时间:2015-07-26 12:45:45      阅读:133      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享
 The Broken Pedometer 

The Problem

A marathon runner uses a pedometer with which he is having problems. In the pedometer the symbols are represented by seven segments (or LEDs):

技术分享

But the pedometer does not work properly (possibly the sweat affected the batteries) and only some of the LEDs are active. The runner wants to know if all the possible symbols:

技术分享

can be correctly identified. For example, when the active LEDs are:

技术分享

numbers 2 and 3 are seen as:

技术分享

so they cannot be distinguished. But when the active LEDs are:

技术分享

the numbers are seen as:

技术分享

and all of them have a different representation.

Because the runner teaches algorithms at University, and he has some hours to think while he is running, he has thought up a programming problem which generalizes the problem of his sweat pedometer. The problem consists of obtaining the minimum number of active LEDs necessary to identify each one of the symbols, given a number P of LEDs, and N symbols to be represented with these LEDs (along with the codification of each symbol).

For example, in the previous sample P = 7 and N = 10. Supposing the LEDs are numbered as:

技术分享

The codification of the symbols is: "0" = 1 1 1 0 1 1 1; "1" = 0 0 1 0 0 1 0; "2" = 1 0 1 1 1 0 1; "3" = 1 0 1 1 0 1 1; "4" = 0 1 1 1 0 1 0; "5" = 1 1 0 1 0 1 1; "6" = 1 1 0 1 1 1 1; "7" = 1 0 1 0 0 1 1; "8" = 1 1 1 1 1 1 1; "9" = 1 1 1 1 0 1 1. In this case, LEDs 5 and 6 can be suppressed without losing information, so the solution is 5.

The Input

The input file consists of a first line with the number of problems to solve. Each problem consists of a first line with the number of LEDs (P), a second line with the number of symbols (N), and N lines each one with the codification of a symbol. For each symbol, the codification is a succession of 0s and 1s, with a space between them. A 1 means the corresponding LED is part of the codification of the symbol. The maximum value of P is 15 and the maximum value of N is 100. All the symbols have different codifications.

The Output

The output will consist of a line for each problem, with the minimum number of active LEDs necessary to identify all the given symbols.

Sample Input

2
7
10
1 1 1 0 1 1 1
0 0 1 0 0 1 0
1 0 1 1 1 0 1
1 0 1 1 0 1 1
0 1 1 1 0 1 0
1 1 0 1 0 1 1
1 1 0 1 1 1 1
1 0 1 0 0 1 0
1 1 1 1 1 1 1
1 1 1 1 0 1 1
6
10
0 1 1 1 0 0
1 0 0 0 0 0
1 0 1 0 0 0
1 1 0 0 0 0
1 1 0 1 0 0
1 0 0 1 0 0
1 1 1 0 0 0
1 1 1 1 0 0
1 0 1 1 0 0
0 1 1 0 0 0

Sample Output

5
4
此题目最重要的是看懂,他的大概意思是给你个P代表着有多少位,给你个N代表着有多少个数
最终要你求,每个数改变相同的位(题目是直接删掉相同的位,即关掉LED,让他不能运行),最多改变多少,剩下的位依旧可以表示独特性,即每一个数都不相同,都可以识别出来
所以直接用DFS枚举所有的情况(中间剪枝一小部分)即可。
/*
Author: 2486
Memory: 0 KB		Time: 33 MS
Language: C++ 4.8.2		Result: Accepted
VJ RunId: 4153206		Real RunId: 15826224
Public:		No Yes
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n,p,t,maps[105][105],Max,ind[20],ds[100+5];
bool vis[20];
bool C(int m) {
    int s;
    memset(vis,false,sizeof(vis));
    for(int i=0; i<m; i++) {
        vis[ind[i]]=true;
    }
    for(int i=0; i<n; i++) {
        s=0;
        for(int j=0; j<p; j++) {
            if(!vis[j]) {
                s=s*2+maps[i][j];
            }
        }
        ds[i]=s;
    }
    sort(ds,ds+n);
    for(int i=1; i<n; i++) {
        if(ds[i]==ds[i-1])return false;
    }
    return true;
}
void dfs(int col,int num) {
    if(!C(num))return;
    if(col>=p) {
        Max=max(Max,num);
        return ;
    }
    ind[num]=col;
    dfs(col+1,num+1);
    dfs(col+1,num);
}
int main() {
    scanf("%d",&t);
    while(t--) {
        scanf("%d%d",&p,&n);
        for(int i=0; i<n; i++) {
            for(int j=0; j<p; j++) {
                scanf("%d",&maps[i][j]);
            }
        }
        Max=0;
        dfs(0,0);
        printf("%d\n",p-Max);
    }
    return 0;
}


 Status

版权声明:本文为博主原创文章,未经博主允许不得转载。

The broken pedometer-纯暴力枚举

标签:

原文地址:http://blog.csdn.net/qq_18661257/article/details/47066447

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!