码迷,mamicode.com
首页 > 其他好文 > 详细

Rescue zoj1649 优先队列

时间:2015-07-26 15:47:49      阅读:86      评论:0      收藏:0      [点我收藏+]

标签:

Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel’s friends want to save Angel. Their task is: approach Angel. We assume that “approach Angel” is to get to the position where Angel stays. When there’s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. “.” stands for road, “a” stands for Angel, and “r” stands for each of Angel’s friend.

Process to the end of the file.

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing “Poor ANGEL has to stay in the prison all his life.”

Sample Input
7 8

.#####.

.a#..r.

..#x…

..#..#.#

…##..

.#……
……..

Sample Output
13

优先队列,遇到守卫当两步处理。其他按一步处理,每次从队列中找出,步数最少的进行操作,直到找到结果。

#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int cnv[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
struct Rac{
    int x,y,cnt;
    bool operator < (const Rac & p) const{
       return cnt > p.cnt;
    }
};

char mp[205][205];
int visit[205][205];
int sx,sy,tx,ty;
int n,m;
int main()
{
    while(scanf("%d %d",&m,&n)==2)
    {
        int i,j;
        getchar();
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%c",&mp[i][j]);
                if(mp[i][j]==‘r‘)
                {
                    sx=i;
                    sy=j;
                }
                else if(mp[i][j]==‘a‘)
                {
                    tx=i;
                    ty=j;
                }
            }
            getchar();
        }
        memset(visit,0,sizeof(visit));
        priority_queue<Rac>q;
        Rac s;
        s.x=sx;
        s.y=sy;
        s.cnt=0;
        visit[sx][sy]=1;
        q.push(s);
        bool ok=false;

        while(!ok&&q.empty()==false)
        {
            Rac t=q.top();
            q.pop();
            for(i=0;i<4;i++)
            {
                int x=t.x+cnv[i][0];
                int y=t.y+cnv[i][1];
                if(x>=0&&x<m&&y>=0&&y<n&&visit[x][y]==0&&mp[x][y]!=‘#‘)
                {
                    if(mp[x][y]==‘.‘)
                    {
                        visit[x][y]=1;
                        Rac t2;
                        t2.x=x;
                        t2.y=y;
                        t2.cnt=t.cnt+1;
                        q.push(t2);
                    }
                    else if(mp[x][y]==‘x‘)
                    {
                        visit[x][y]=1;
                        Rac t2;
                        t2.x=x;
                        t2.y=y;
                        t2.cnt=t.cnt+2;
                        q.push(t2);
                    }
                    else if(mp[x][y]==‘a‘)
                    {
                        ok=true;
                        printf("%d\n",t.cnt+1);
                        break;
                    }
                }
            }
        }
        if(!ok) printf("Poor ANGEL has to stay in the prison all his life.\n"); //不能到达
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Rescue zoj1649 优先队列

标签:

原文地址:http://blog.csdn.net/xtulollipop/article/details/47068201

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!