码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1212 Big Number

时间:2015-07-26 15:50:00      阅读:93      评论:0      收藏:0      [点我收藏+]

标签:

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5984    Accepted Submission(s): 4182


Problem Description
As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
2 3 12 7 152455856554521 3250
 

Sample Output
2 5 1521
 

Author
Ignatius.L
 

Source
 

思路:

     对大数取余,需要将大数(原来在字符串中的)转换到整型数组里面,从最高位开始对正整数c取余,最终输出c的余数就行了!

代码:

 

#include <stdio.h>
#include <string.h>
#define N 1005
char a[N];
int b[N];
int main()
{
	int len,n,i,j,k,t,s,c;
	while(scanf("%s%d",a,&c)!=EOF)
	{
		memset(b,0,sizeof(b));
		len=strlen(a);
	    for(i=0;i<len;i++)//将位将字符转换成数字,保存到整形数组里面!(注:a[0]保存的是最高位!) 
	       b[i]=a[i]-'0';
	    for(i=0,t=0;i<len;i++)	
	    {
	    	
	          t=t*10+b[i];	
	          t=t%c;//从最高位开始逐位对c取余! 
	    }
	    printf("%d\n",t);
	}
	return 0;
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1212 Big Number

标签:

原文地址:http://blog.csdn.net/dxx_111/article/details/47067863

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!