码迷,mamicode.com
首页 > 其他好文 > 详细

HPU 1002 A + B Problem II

时间:2015-07-26 17:26:40      阅读:83      评论:0      收藏:0      [点我收藏+]

标签:

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 261413    Accepted Submission(s): 50581


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

思路:

       将数字以字符的形式存储到字符数组中,因为在存储的时候是高位在以0为下标的下标变量中存储的,所以要将其进行翻转,存储到整形数组中(也就是高位存储到大下标变量中,因为在进位的时候能在原来的基础上进行i++,来存储最高位的数据),然后将两个大数按位相加,如果比十大,进行进位操作!
 

代码:

#include <stdio.h>
#include <string.h>
#define N 10005
char a[N],b[N];
int c[N],d[N];
int main()
{
	int n,i,j,k,len1,len2;
	scanf("%d",&n);
	k=n;
	while(n--)
	{
		memset(c,0,sizeof(c));//每次都得清零,所以得放到while循环里面! 
	    memset(d,0,sizeof(d));
		getchar();
		scanf("%s%s",a,b);//空格也是scanf的分割符! 
		len1=strlen(a);
		len2=strlen(b);
		for(i=len1-1,j=0;i>=0;i--)//因为需要逆序保存,所以应该设变量j从0开始! 
		  c[j++]=a[i]-'0';
		for(i=len2-1,j=0;i>=0;i--)
		  d[j++]=b[i]-'0';
		for(i=0;i<1001;i++)
		  {
		  c[i]+=d[i];
		   if(c[i]>=10)
		   {
		   	c[i]-=10;
		   	c[i+1]++;
		   }
	      }
	    printf("Case %d:\n%s + %s = ",k-n,a,b);
	    for(i=1000;i>=0&&c[i]==0;i--);
	    if(i>=0)
	      for(;i>=0;i--)
	      {
	      	printf("%d",c[i]);
	      }
	    else
	      printf("0");
	    printf("\n");
	    if(n!=0)
	      printf("\n");
	}
	return 0;
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

HPU 1002 A + B Problem II

标签:

原文地址:http://blog.csdn.net/dxx_111/article/details/47069137

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!