码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 题目3264 Balanced Lineup(RMQ)

时间:2015-07-26 17:27:48      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:

Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 39046   Accepted: 18291
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver

ac代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#define max(a,b) (a>b?a:b)
#define min(a,b) (a>b?b:a)
int minv[50050][20],maxv[50050][20];
int a[50050];
void init(int n)
{
	int i,j,k;
	for(i=1;i<=n;i++)
	{
		maxv[i][0]=minv[i][0]=a[i];
	}
	for(j=1;(1<<j)<=n;j++)
	{
		for(k=1;k+(1<<j)-1<=n;k++)
		{
			minv[k][j]=min(minv[k][j-1],minv[k+(1<<(j-1))][j-1]);
			maxv[k][j]=max(maxv[k][j-1],maxv[k+(1<<(j-1))][j-1]);
		}
	}
}
int q_max(int l,int r)
{
	int k=(int)(log((double)(r-l+1))/(log(2.0)));
	return max(maxv[l][k],maxv[r-(1<<k)+1][k]);
}
int q_min(int l,int r)
{
	int k=(int)(log((double)(r-l+1))/(log(2.0)));
	return min(minv[l][k],minv[r-(1<<k)+1][k]);
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		init(n);
		while(m--)
		{
			int l,r;
			scanf("%d%d",&l,&r);
			printf("%d\n",q_max(l,r)-q_min(l,r));
		}
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 题目3264 Balanced Lineup(RMQ)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/47068793

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!