码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 1005Number Sequence

时间:2015-07-26 20:58:36      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:



/*Number Sequence
Problem Description

A number sequence is defined as follows
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B
and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000).
Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5*/


<span style="font-size:18px;"># include<stdio.h>
main()
{
    int f[100];
 int a,b,i;
    int n;
 while(scanf("%d%d%d",&a,&b,&n),a,b,n)
 {
  f[0]=1;
  f[1]=1;
  for(i=2;i<48;i++)
  {
   f[i]=(a*f[i-1]+b*f[i-2])%7;
  }
  n=(n-1)%48;
  printf("%d\n",f[n]);
 }
}</span>

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj 1005Number Sequence

标签:

原文地址:http://blog.csdn.net/qjt19950610/article/details/47071017

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!