码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1837 Balance(DP)

时间:2015-07-27 00:22:20      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   dp   

Balance
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 11806   Accepted: 7368

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm‘s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
? the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
? the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-‘ for the left arm and ‘+‘ for the right arm); 
? on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights‘ values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

给出C个挂钩的位置以及G个重物的质量,求有几种方式使得天平平衡。

这道题乍看要用搜索,其实DP就可以。dp[i][j]表示挂完前i个重物能使力矩为j的情况种数,j=0时表示平衡。
所以状态转移方程就是dp[i][k+loc[j]*wei[i]]+=dp[i-1][k],表示前(i-1)个重物挂完后合力矩为k,这时在第j个挂钩处挂上重物i,则两者要相加,即dp[i][k+loc[j]*wei[i]]就要加上dp[i-1][k]。

有一点要注意,力矩可能为负数,所以dp数组的下标可能越界,所以要把力矩加上一个力矩数达不到的数,以防止下标越界。

#include<stack>
#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#pragma commment(linker,"/STACK: 102400000 102400000")
#define mset0(t) memset(t,0,sizeof(t))
#define lson a,b,l,mid,cur<<1
#define rson a,b,mid+1,r,cur<<1|1
using namespace std;
const double eps=1e-6;
const int MAXN=20+5;

int loc[MAXN],wei[MAXN],n,m,dp[MAXN][31000];

int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        mset0(dp);
        for(int i=1;i<=n;i++)
            scanf("%d",&loc[i]);
        for(int i=1;i<=m;i++)
            scanf("%d",&wei[i]);
        dp[0][10000]=1;
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++)
                //for(int k=0;k<=21000;k++)//其实这样也能过。。。
                for(int k=loc[j]*wei[i]<0?-1*loc[j]*wei[i]:0;k<=21000;k++)
                    dp[i][k+loc[j]*wei[i]]+=dp[i-1][k];
        printf("%d\n",dp[m][10000]);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 1837 Balance(DP)

标签:acm   算法   dp   

原文地址:http://blog.csdn.net/noooooorth/article/details/47073881

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!