码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5310 Hidden String(暴力枚举)

时间:2015-07-27 00:27:06      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:

Hidden String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 429    Accepted Submission(s): 161


Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, gets a string s of length n. He wants to find three nonoverlapping substrings s[l1..r1]s[l2..r2]s[l3..r3] that:

1. 1l1r1<l2r2<l3r3n

2. The concatenation of s[l1..r1]s[l2..r2]s[l3..r3] is "anniversary".
 

Input
There are multiple test cases. The first line of input contains an integer T (1T100), indicating the number of test cases. For each test case:

There‘s a line containing a string s (1|s|100) consisting of lowercase English letters.
 

Output
For each test case, output "YES" (without the quotes) if Soda can find such thress substrings, otherwise output "NO" (without the quotes).
 

Sample Input
2 annivddfdersewwefary nniversarya
 

Sample Output
YES NO
 

Source
 

问题描述
今天是BestCoder一周年纪念日. 比赛管理员Soda有一个长度为n的字符串s. 他想要知道能否找到s的三个互不相交的子串s[l1..r1], s[l2..r2], s[l3..r3]满足下列条件:

  1. 1l1r1<l2r2<l3r3n

  2. s[l1..r1], s[l2..r2], s[l3..r3]依次连接之后得到字符串"anniversary".
输入描述
输入有多组数据. 第一行有一个整数T (1T100), 表示测试数据组数. 然后对于每组数据:

一行包含一个仅含小写字母的字符串s (1|s|100).
输出描述
对于每组数据, 如果Soda可以找到这样三个子串, 输出"YES", 否则输出"NO".
输入样例
2
annivddfdersewwefary
nniversarya
输出样例
YES
NO

解题思路:枚举三个子字符串,查找。

代码如下:

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<ctime>
#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include<deque>
#include<list>
#include<set>
#include<map>
#include<stack>
#include<queue>
#include<numeric>
#include<iomanip>
#include<bitset>
#include<sstream>
#include<fstream>
#include<limits.h>
#define debug "output for debug\n"
#define pi (acos(-1.0))
#define eps (1e-4)
#define inf (1<<28)
#define sqr(x) (x) * (x)
#define mod 1e9+7
using namespace std;
typedef long long ll;
typedef unsigned long long ULL;
int main()
{
    int i,j,k,n,flag,t;
    char s[200],S[]="anniversary";
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",s);
        n=strlen(s);
        flag=0;
        for(i=0;i<=8;i++)
        {
            for(j=i+1;j<=9;j++)
            {
                k=0;
                while(k<n&&strncmp(S,s+k,i+1)!=0)
                    k++;
                if(k==n)
                    continue;
                k+=i+1;
                while(k<n&&strncmp(S+i+1,s+k,j-i)!=0)
                    k++;
                if(k==n)
                    continue;
                k+=j-i;
                while(k<n&&strncmp(S+j+1,s+k,10-j)!=0)
                    k++;
                if(k!=n)
                {
                    flag=1;
                    break;
                }
            }
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5310 Hidden String(暴力枚举)

标签:

原文地址:http://blog.csdn.net/yanghuaqings/article/details/47066683

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!