码迷,mamicode.com
首页 > 其他好文 > 详细

UVA10780 Again Prime? No time.

时间:2015-07-27 10:40:18      阅读:92      评论:0      收藏:0      [点我收藏+]

标签:

          Again Prime? No time.

The problem statement is very easy. Given a number n you have to determine the largest power of m,
not necessarily prime, that divides n!.


Input
The input file consists of several test cases. The first line in the file is the number of cases to handle.
The following lines are the cases each of which contains two integers m (1 < m < 5000) and n
(0 < n < 10000). The integers are separated by an space. There will be no invalid cases given and
there are not more that 500 test cases.


Output
For each case in the input, print the case number and result in separate lines. The result is either an
integer if m divides n! or a line ‘Impossible to divide’ (without the quotes). Check the sample input
and output format.


Sample Input
2
2 10
2 100


Sample Output
Case 1:
8
Case 2:
97

 

题意:给出m,n;求n!可以整除m的个数

tip:计算它的质因子,然后求其最小幂

 

#include<iostream>
#include<cstdio>
#include<algorithm>

using namespace std;

int main()
{
    int t,c=1;
    cin>>t;
    while(t--)
    {
        int m,n,p,ans=1000000,a,b;
        cin>>m>>n;
        for(int i=2;m!=1;i++)
        {
            int p=0;
            while(m%i==0)
            {
                m/=i;
                p++;
            }

            if(p)
            {
                a=n;///开始用n
                b=0;///出现次数
                while(a)
                {
                    b+=a/i;
                    a/=i;
                }
                ans=min(ans,b/p);
            }
        }
        cout<<"Case "<<c++<<":"<<endl;
        if(ans==0)
            cout<<"Impossible to divide\n";
        else
            cout<<ans<<endl;
    }
    return 0;
}

 

UVA10780 Again Prime? No time.

标签:

原文地址:http://www.cnblogs.com/moqitianliang/p/4679314.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!